aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-06-28 07:57:38 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-06-28 08:00:24 +0000
commit9399e65be9a94c93365d8f6f059ac9d4e097ce69 (patch)
treebe1e28e40956556dc4be55523a8159e5e5585e15
parenta4c62a931c4c5560a034806f887ecd6a0de38627 (diff)
downloadports-9399e65be9a94c93365d8f6f059ac9d4e097ce69.tar.gz
ports-9399e65be9a94c93365d8f6f059ac9d4e097ce69.zip
x11/{lightdm,sddm}: add CONFLICTS
Both lightdm and sddm install the DBus file for DisplayManager, etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf It doesn't really make sense to install multiple DMs on one machine, but for completeness in the ports framework, mark them as conflicting. PR: 256688 256687 Reported by: Graham Perrin
-rw-r--r--x11/lightdm/Makefile4
-rw-r--r--x11/sddm/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/x11/lightdm/Makefile b/x11/lightdm/Makefile
index 4b2646f27016..9fbb9d37eba1 100644
--- a/x11/lightdm/Makefile
+++ b/x11/lightdm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= lightdm
PORTVERSION= 1.30.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= https://github.com/CanonicalLtd/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
@@ -30,6 +30,8 @@ USE_XORG= x11 xcb xdmcp
USE_LDCONFIG= yes
USE_RC_SUBR= lightdm
+CONFLICTS_INSTALL= sddm
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests # PAM errors
INSTALL_TARGET= install-strip
diff --git a/x11/sddm/Makefile b/x11/sddm/Makefile
index 001501c87eb6..7a7271f28433 100644
--- a/x11/sddm/Makefile
+++ b/x11/sddm/Makefile
@@ -1,7 +1,7 @@
PORTNAME= sddm
PORTVERSION= 0.19.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MAINTAINER= kde@FreeBSD.org
@@ -26,6 +26,8 @@ USE_QT= core declarative dbus gui network \
buildtools_build linguisttools_build qmake_build
USE_XORG= xcb
+CONFLICTS_INSTALL= lightdm
+
CMAKE_ON= BUILD_MAN_PAGES
CMAKE_ARGS= -DUID_MIN=1000 \
-DUID_MAX=65000 \