aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2021-06-20 08:54:49 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2021-06-20 09:06:11 +0000
commit942a4d428e389e5abc61b5957fc37c4f758ff919 (patch)
tree861d613ec69cb147fd1306412774c46ee3e17a7e
parent1b62862f143abe52c91f69e09c024d8814fd6b95 (diff)
downloadports-942a4d428e389e5abc61b5957fc37c4f758ff919.tar.gz
ports-942a4d428e389e5abc61b5957fc37c4f758ff919.zip
misc/openhab2*: switch to new download location, specify JAVA_VERSION
- switch to new download location (and zip instead of tgz) - set JAVA_VERSION in the start script, to allow coexistence with the upcoming v3 port - while I'm here, please portlint a little bit in maintainer specifc parts
-rw-r--r--misc/openhab2-addons/Makefile6
-rw-r--r--misc/openhab2-addons/distinfo6
-rw-r--r--misc/openhab2/Makefile19
-rw-r--r--misc/openhab2/distinfo6
-rw-r--r--misc/openhab2/files/openhab2.in1
5 files changed, 18 insertions, 20 deletions
diff --git a/misc/openhab2-addons/Makefile b/misc/openhab2-addons/Makefile
index e348974f7f18..e2698c69520e 100644
--- a/misc/openhab2-addons/Makefile
+++ b/misc/openhab2-addons/Makefile
@@ -1,9 +1,7 @@
-# Created by: Alexander Leidinger
-
PORTNAME= openhab2-addons
-PORTVERSION= 2.5.11
+PORTVERSION= 2.5.12
CATEGORIES= misc java
-MASTER_SITES= https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab-addons%2F${PORTVERSION}/
+MASTER_SITES= https://openhab.jfrog.io/artifactory/libs-release-local/org/openhab/distro/openhab-addons//${PORTVERSION}/
DISTNAME= openhab-addons-${PORTVERSION}
EXTRACT_SUFX= .kar
diff --git a/misc/openhab2-addons/distinfo b/misc/openhab2-addons/distinfo
index f04a06509833..54e3ff67c3c4 100644
--- a/misc/openhab2-addons/distinfo
+++ b/misc/openhab2-addons/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1607929665
-SHA256 (openhab-addons-2.5.11.kar) = 400b1272f7eef2e2c565df6fee7a2fab098dfdfe623c525436b67154a1f07a1c
-SIZE (openhab-addons-2.5.11.kar) = 199393963
+TIMESTAMP = 1620371585
+SHA256 (openhab-addons-2.5.12.kar) = 6544a323af11f577dde736f6942c5833879d0b41770700fcc667a188755c6cce
+SIZE (openhab-addons-2.5.12.kar) = 199511513
diff --git a/misc/openhab2/Makefile b/misc/openhab2/Makefile
index ff3206b66c8f..d822ffa6dff4 100644
--- a/misc/openhab2/Makefile
+++ b/misc/openhab2/Makefile
@@ -1,10 +1,8 @@
-# Created by: Alexander Leidinger
-
PORTNAME= openhab2
-PORTVERSION= 2.5.11
-PORTREVISION= 0
+PORTVERSION= 2.5.12
+#PORTREVISION= 0
CATEGORIES= misc java
-MASTER_SITES= https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab%2F${PORTVERSION}/
+MASTER_SITES= https://openhab.jfrog.io/artifactory/libs-release-local/org/openhab/distro/openhab/${PORTVERSION}/
DISTNAME= openhab-${PORTVERSION}
MAINTAINER= netchild@FreeBSD.org
@@ -13,6 +11,7 @@ COMMENT= Vendor and technology agnostic open source smart-home software
LICENSE= EPL
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.8
JAVA_RUN= yes
@@ -66,13 +65,13 @@ do-install:
(cd ${WRKSRC}/userdata && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/${PORTNAME})
gen-plist:
- ${FIND} ${STAGEDIR} -type f | sed -e "s:${STAGEDIR}${PREFIX}/::g ; s:${PORTVERSION}:%%PORTVERSION%%:g" | sort -u | grep libexec/ >pkg-plist.new
+ ${FIND} ${STAGEDIR} -type f | ${SED} -e "s:${STAGEDIR}${PREFIX}/::g ; s:${PORTVERSION}:%%PORTVERSION%%:g" | ${SORT} -u | ${GREP} libexec/ >pkg-plist.new
echo '@owner openhab' >>pkg-plist.new
echo '@group openhab' >>pkg-plist.new
- ${FIND} ${STAGEDIR}${DATADIR} -type f | sed -E -e "s:${STAGEDIR}${DATADIR}/(.*):@sample %%DATADIR%%/\\1 /var/db/openhab2/userdata/\\1:g ; s:${PORTVERSION}:%%PORTVERSION%%:g" | sort -u >>pkg-plist.new
- ${FIND} ${STAGEDIR}${ETCDIR} -type d | sort -u | sed -e "s:${STAGEDIR}${ETCDIR}:@dir %%ETCDIR%%:g ; s:${PORTVERSION}:%%PORTVERSION%%:g" >>pkg-plist.new
- ${FIND} ${STAGEDIR}${ETCDIR} -type f | sort -u | sed -E -e "s:${STAGEDIR}${ETCDIR}/:%%ETCDIR%%/:g ; s:${PORTVERSION}:%%PORTVERSION%%:g ; s:(.*.sample)$:@sample(openhab,openhab,640) \\1:" >>pkg-plist.new
- ${FIND} ${STAGEDIR}/var/db/${PORTNAME} -type d | sort -ru | sed -e "s:${STAGEDIR}:@dir :g" >>pkg-plist.new
+ ${FIND} ${STAGEDIR}${DATADIR} -type f | ${SED} -E -e "s:${STAGEDIR}${DATADIR}/(.*):@sample %%DATADIR%%/\\1 /var/db/openhab2/userdata/\\1:g ; s:${PORTVERSION}:%%PORTVERSION%%:g" | ${SORT} -u >>pkg-plist.new
+ ${FIND} ${STAGEDIR}${ETCDIR} -type d | ${SORT} -u | ${SED} -e "s:${STAGEDIR}${ETCDIR}:@dir %%ETCDIR%%:g ; s:${PORTVERSION}:%%PORTVERSION%%:g" >>pkg-plist.new
+ ${FIND} ${STAGEDIR}${ETCDIR} -type f | ${SORT} -u | ${SED} -E -e "s:${STAGEDIR}${ETCDIR}/:%%ETCDIR%%/:g ; s:${PORTVERSION}:%%PORTVERSION%%:g ; s:(.*.sample)$:@sample(openhab,openhab,640) \\1:" >>pkg-plist.new
+ ${FIND} ${STAGEDIR}/var/db/${PORTNAME} -type d | ${SORT} -ru | ${SED} -e "s:${STAGEDIR}:@dir :g" >>pkg-plist.new
echo "@dir /var/log/${PORTNAME}" >>pkg-plist.new
echo "@dir /var/run/${PORTNAME}" >>pkg-plist.new
diff --git a/misc/openhab2/distinfo b/misc/openhab2/distinfo
index 7fc4dacf77dd..c7fecde4b081 100644
--- a/misc/openhab2/distinfo
+++ b/misc/openhab2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1607929490
-SHA256 (openhab-2.5.11.tar.gz) = edff418da20464fc3fbc28f9790b122c53ddb8a53bf4f79041a7645c0ba49ac8
-SIZE (openhab-2.5.11.tar.gz) = 83126702
+TIMESTAMP = 1624176344
+SHA256 (openhab-2.5.12.zip) = 681007f4ddeba4e06c2f83b03dfb0ece5ffa4d35708db965d565b332fae7f1c7
+SIZE (openhab-2.5.12.zip) = 83479526
diff --git a/misc/openhab2/files/openhab2.in b/misc/openhab2/files/openhab2.in
index 5cb5b25fc780..60f438f6d00c 100644
--- a/misc/openhab2/files/openhab2.in
+++ b/misc/openhab2/files/openhab2.in
@@ -58,6 +58,7 @@ export OPENHAB_USERDATA="${openhab2_userdata_dir}"
export OPENHAB_LOGDIR="${openhab2_log_dir}"
# for UTF-8 encoding, language can be set inside openhab:
export LC_ALL=en_US.UTF-8
+export JAVA_VERSION=8
pidfile=/var/run/${name}/${name}.pid