aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-06-06 18:22:35 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-06-06 18:22:35 +0000
commit943dba8675cc9649293c932eaed5bbb4e4562660 (patch)
tree332c7b5fc06c209c14f9d666ec7851a9de4a809a
parentd362e6d9dbb4a8d3e1692175df7434973c6f5e7f (diff)
downloadports-943dba8675cc9649293c932eaed5bbb4e4562660.tar.gz
ports-943dba8675cc9649293c932eaed5bbb4e4562660.zip
sysutils/b2sum: Install manpage and enable OPENMP on some architectures
- Bump PORTREVISION for package change PR: 279558 Requested by: fuz
-rw-r--r--sysutils/b2sum/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/sysutils/b2sum/Makefile b/sysutils/b2sum/Makefile
index b3408ec601ae..95252b7d90e5 100644
--- a/sysutils/b2sum/Makefile
+++ b/sysutils/b2sum/Makefile
@@ -1,11 +1,12 @@
PORTNAME= b2sum
PORTVERSION= 20190724
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils security
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fast secure hashing
-WWW= https://blake2.net/
+WWW= https://blake2.net/ \
+ https://github.com/BLAKE2/BLAKE2
LICENSE= CC0-1.0
LICENSE_FILE= ${WRKSRC}/../COPYING
@@ -15,13 +16,17 @@ MAKEFILE= makefile
USE_CSTD= c99
WRKSRC_SUBDIR= b2sum
-PLIST_FILES= bin/b2sum
+PLIST_FILES= bin/b2sum \
+ share/man/man1/b2sum.1.gz
USE_GITHUB= yes
GH_ACCOUNT= BLAKE2
GH_PROJECT= BLAKE2
OPTIONS_DEFINE= OPENMP OPTIMIZED_CFLAGS SSE
+.if exists(/usr/include/omp.h)
+OPTIONS_DEFAULT+= OPENMP
+.endif
OPTIONS_DEFAULT_amd64= SSE
SSE_DESC= Use SSE2, SSSE3, SSE4.1, AVX or XOP instructions
@@ -44,6 +49,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-makefile
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/b2sum ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/b2sum ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/b2sum.1 ${STAGEDIR}${PREFIX}/share/man/man1/
.include <bsd.port.mk>