aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:42:27 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:30 +0000
commit95203371dfaa957fc577320bb06ea533426be241 (patch)
tree70387704f44921a2fcba88f61695485b23653edf
parentd6dedd1727dcdf17b57ae26b6e2892bc4aa299e1 (diff)
downloadports-95203371dfaa957fc577320bb06ea533426be241.tar.gz
ports-95203371dfaa957fc577320bb06ea533426be241.zip
devel/py-aioitertools: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-aioitertools/Makefile9
-rw-r--r--devel/py-aioitertools/files/setup.py25
2 files changed, 5 insertions, 29 deletions
diff --git a/devel/py-aioitertools/Makefile b/devel/py-aioitertools/Makefile
index de715cd9c3f6..487919c52cb4 100644
--- a/devel/py-aioitertools/Makefile
+++ b/devel/py-aioitertools/Makefile
@@ -1,5 +1,6 @@
PORTNAME= aioitertools
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,18 +12,18 @@ WWW= https://github.com/omnilib/aioitertools
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.2<4:devel/py-flit-core@${PY_FLAVOR}
+
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 31000
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0:devel/py-typing-extensions@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0:devel/py-typing-extensions@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
diff --git a/devel/py-aioitertools/files/setup.py b/devel/py-aioitertools/files/setup.py
deleted file mode 100644
index 054135172842..000000000000
--- a/devel/py-aioitertools/files/setup.py
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['aioitertools', 'aioitertools.tests']
-
-package_data = \
-{'': ['*']}
-
-extras_require = \
-{":python_version < '3.10'": ['typing_extensions>=4.0']}
-
-setup(name='aioitertools',
- version='%%PORTVERSION%%',
- description='itertools and builtins for AsyncIO and mixed iterables',
- author='Amethyst Reese',
- author_email='amy@noswap.com',
- url='https://aioitertools.omnilib.dev',
- packages=packages,
- package_data=package_data,
- extras_require=extras_require,
- python_requires='>=3.6',
- )