aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:34:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:00:17 +0000
commit95cf3f39d80a531756677a3345bb033f4808bdc5 (patch)
treec4a7153d84d8ad0addc7b598e2dfd00be9b30bca
parentd25899a4d1f4f9a9f426ae13e88751e213c1980f (diff)
downloadports-95cf3f39d80a531756677a3345bb033f4808bdc5.tar.gz
ports-95cf3f39d80a531756677a3345bb033f4808bdc5.zip
security/py-sslyze: Update to 5.1.0
-rw-r--r--security/py-sslyze/Makefile10
-rw-r--r--security/py-sslyze/distinfo6
-rw-r--r--security/py-sslyze/files/patch-setup.py14
3 files changed, 8 insertions, 22 deletions
diff --git a/security/py-sslyze/Makefile b/security/py-sslyze/Makefile
index 5c586da4864f..7951b7a43d31 100644
--- a/security/py-sslyze/Makefile
+++ b/security/py-sslyze/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sslyze
-PORTVERSION= 5.0.5
-PORTREVISION= 3
+PORTVERSION= 5.1.0
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +11,11 @@ WWW= https://github.com/nabla-c0d3/sslyze
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6,1<39.0.0,1:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}nassl>=4.0.1<5.0.0:security/py-nassl@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6,1<39,1:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nassl>=5<6:security/py-nassl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.7<1.11:devel/py-pydantic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tls-parser>=2.0.0<3.0.0:security/py-tls-parser@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}openssl>=20,1<23,1:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tls-parser>=2<3:security/py-tls-parser@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
diff --git a/security/py-sslyze/distinfo b/security/py-sslyze/distinfo
index edc4eb2a6d6f..8c9aad2f06b9 100644
--- a/security/py-sslyze/distinfo
+++ b/security/py-sslyze/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656092884
-SHA256 (sslyze-5.0.5.tar.gz) = fea82ad88a030cc0978fb55f632849b3e858e03c5b97fd62459976953d3ef5d5
-SIZE (sslyze-5.0.5.tar.gz) = 985910
+TIMESTAMP = 1674590004
+SHA256 (sslyze-5.1.0.tar.gz) = 5b229dc7d72734d14a4e85799a40bf1867b1ad3ea88ad6b1901517974b402b53
+SIZE (sslyze-5.1.0.tar.gz) = 979438
diff --git a/security/py-sslyze/files/patch-setup.py b/security/py-sslyze/files/patch-setup.py
deleted file mode 100644
index 96adc8f743cd..000000000000
--- a/security/py-sslyze/files/patch-setup.py
+++ /dev/null
@@ -1,14 +0,0 @@
---- setup.py.orig 2022-05-14 09:12:21 UTC
-+++ setup.py
-@@ -98,9 +98,9 @@ setup(
- # Dependencies
- install_requires=[
- "nassl>=4.0.1,<5.0.0",
-- "cryptography>=2.6,<38.0.0",
-+ "cryptography>=2.6,<39.0.0",
- "tls-parser>=2.0.0,<3.0.0",
-- "pydantic>=1.7,<1.10",
-+ "pydantic>=1.7,<1.11",
- ],
- # cx_freeze info for Windows builds with Python embedded
- options={"build_exe": {"packages": ["cffi", "cryptography"], "include_files": get_include_files()}},