aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-17 22:24:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-17 22:41:21 +0000
commit96149ad2bb06b6678209d7b303ae0c9f855f8c44 (patch)
tree39bb69e97926796ceeb4db873afb32490591ae00
parent6e78c8e663cbfc4ea782b012ed0c1d59c1ecc7ff (diff)
downloadports-96149ad2bb06b6678209d7b303ae0c9f855f8c44.tar.gz
ports-96149ad2bb06b6678209d7b303ae0c9f855f8c44.zip
science/libnegf: Add options; Correct license
-rw-r--r--science/libnegf/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/science/libnegf/Makefile b/science/libnegf/Makefile
index 1a2a8e897a50..4fe3baaacf38 100644
--- a/science/libnegf/Makefile
+++ b/science/libnegf/Makefile
@@ -1,15 +1,16 @@
PORTNAME= libnegf
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= science # chemistry
MAINTAINER= yuri@FreeBSD.org
COMMENT= Non Equilibrium Green's Functions library
-LICENSE= MPL20
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= GPLv3
-LIB_DEPENDS= libopenblas.so:math/openblas
+LIB_DEPENDS= libmpi.so:net/mpich \
+ libopenblas.so:math/openblas
USES= cmake:testing fortran python:build
USE_GITHUB= yes
@@ -18,4 +19,14 @@ CMAKE_ON= BUILD_SHARED_LIBS
BINARY_ALIAS= python=${PYTHON_CMD} python3=${PYTHON_CMD}
+OPTIONS_DEFINE= INELASTIC MPI
+OPTIONS_DEFAULT= MPI # MPI default has to be in sync with science/dftbplus
+
+INELASTIC_DESC= Build with inelastic scattering
+INELASTIC_CMAKE_BOOL= WITH_INELASTIC
+INELASTIC_BROKEN= Error: Can't open included file 'fftw3.f03', see https://github.com/libnegf/libnegf/issues/56
+
+MPI_CMAKE_BOOL= WITH_MPI
+MPI_LIB_DEPENDS= libmpifx.so:net/mpifx
+
.include <bsd.port.mk>