aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Walpen <dev@submerge.ch>2024-01-17 08:30:10 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-01-17 08:52:25 +0000
commit963ccdb8eb509e7fe171b63d6e1fd8ee4c664108 (patch)
tree83f01bec18e0b217f241c024f04562cc1f419859
parentcab98f16d3ff67a1353b0388ed5142c1a53e92a1 (diff)
downloadports-963ccdb8eb509e7fe171b63d6e1fd8ee4c664108.tar.gz
ports-963ccdb8eb509e7fe171b63d6e1fd8ee4c664108.zip
print/pdfmixtool: Fix build after ImageMagick7 7.1.1 update.
iAfter the update to ImageMagick7 7.1.1, build would fail and complain about MAGICKCORE_HDRI_ENABLE not being defined. While pkgconf clearly propagates these additional CFLAGS, the CMakeLists.txt of pdfmixtool does not use them. PR: 276362 Reported by: dev@submerge.ch (maintainer)
-rw-r--r--print/pdfmixtool/Makefile2
-rw-r--r--print/pdfmixtool/files/patch-CMakeLists.txt15
2 files changed, 16 insertions, 1 deletions
diff --git a/print/pdfmixtool/Makefile b/print/pdfmixtool/Makefile
index f5e3b38488e9..7b78798aec08 100644
--- a/print/pdfmixtool/Makefile
+++ b/print/pdfmixtool/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pdfmixtool
DISTVERSION= 1.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print graphics editors
PKGNAMESUFFIX= -${FLAVOR}
diff --git a/print/pdfmixtool/files/patch-CMakeLists.txt b/print/pdfmixtool/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9229066a2c84
--- /dev/null
+++ b/print/pdfmixtool/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2024-01-16 00:28:44 UTC
++++ CMakeLists.txt
+@@ -142,6 +142,12 @@ target_link_libraries (
+ ${QT_LIBRARIES}
+ )
+
++target_compile_options(
++ pdfmixtool
++ PUBLIC
++ ${MAGICK_CFLAGS_OTHER}
++)
++
+ INSTALL(TARGETS pdfmixtool RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ INSTALL(FILES resources/eu.scarpetta.PDFMixTool.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
+ INSTALL(FILES resources/eu.scarpetta.PDFMixTool.appdata.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo)