aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2024-05-22 13:57:17 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2024-05-22 13:57:17 +0000
commit969cda56e5bef5072cbf3fee549888f5051ed987 (patch)
tree2823c3fcbb99a77d6b096067e5e368f07e721fbb
parent01ceeb69a008e98d66aec70fde9afe4d33c8b5c2 (diff)
downloadports-969cda56e5bef5072cbf3fee549888f5051ed987.tar.gz
ports-969cda56e5bef5072cbf3fee549888f5051ed987.zip
misc/py-llm-claude-3: new port - anthropic claude3 lib for py-llm
Differential Revision: https://reviews.freebsd.org/D45269
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-llm-claude-3/Makefile32
-rw-r--r--misc/py-llm-claude-3/distinfo3
-rw-r--r--misc/py-llm-claude-3/pkg-descr1
4 files changed, 37 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index e4a82bb1082f..8d8b696dee82 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -444,6 +444,7 @@
SUBDIR += py-lightning-utilities
SUBDIR += py-litellm
SUBDIR += py-llm
+ SUBDIR += py-llm-claude-3
SUBDIR += py-log_symbols
SUBDIR += py-mffpy
SUBDIR += py-mmcv
diff --git a/misc/py-llm-claude-3/Makefile b/misc/py-llm-claude-3/Makefile
new file mode 100644
index 000000000000..52935e56601a
--- /dev/null
+++ b/misc/py-llm-claude-3/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= llm-claude-3
+DISTVERSION= 0.3
+CATEGORIES= misc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= Interact with Large Language Models by API, or locally
+WWW= https://github.com/simonw/llm-claude-3
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=41:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anthropic>=0.26.0:misc/py-anthropic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}llm>=0.3:misc/py-llm@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/py-llm-claude-3/distinfo b/misc/py-llm-claude-3/distinfo
new file mode 100644
index 000000000000..565a751dee60
--- /dev/null
+++ b/misc/py-llm-claude-3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716202989
+SHA256 (llm-claude-3-0.3.tar.gz) = 82cdbb74cf0992403aacf8dc68c0c1289c5cd667b752138de9bf059753bc5ac6
+SIZE (llm-claude-3-0.3.tar.gz) = 7922
diff --git a/misc/py-llm-claude-3/pkg-descr b/misc/py-llm-claude-3/pkg-descr
new file mode 100644
index 000000000000..5df66002a5f5
--- /dev/null
+++ b/misc/py-llm-claude-3/pkg-descr
@@ -0,0 +1 @@
+Plugin for Anthropic Claude 3, a machine learning large language model.