aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-10-08 09:27:59 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-10-08 09:40:40 +0000
commit96e194fafea582015e3d14ec48653a4734a1a15c (patch)
treed286acf5ed2b4ecf21ef5ae9fa7d4fbd534c8e55
parent85db42c262f23cfdf52b7b87b411c7cf7b8b0332 (diff)
downloadports-96e194fafea582015e3d14ec48653a4734a1a15c.tar.gz
ports-96e194fafea582015e3d14ec48653a4734a1a15c.zip
math/polymake: Remove NATIVE option and add GitHub to MASTER_SITES
* Add GitHub as primary download site and upstream website as backup * Remove NATIVE option, users wanting to apply CPU specific optimization should use CPUTYPE instead using ports framework * Use OPTIMIZED_CFLAGS option to define O3 optimization PR: 273316 Reviewed by: Philipp Ost <bsd@philippost.de> (maintainer) Sponsored by: Blinkinblox
-rw-r--r--math/polymake/Makefile14
-rw-r--r--math/polymake/files/patch-support_configure.pl11
2 files changed, 19 insertions, 6 deletions
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index 4b945d7938b8..9e46f9caafb3 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -1,7 +1,9 @@
PORTNAME= polymake
DISTVERSION= 4.10
+PORTREVISION= 1
CATEGORIES= math
-MASTER_SITES= https://polymake.org/lib/exe/fetch.php/download/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/V${DISTVERSION}/ \
+ https://polymake.org/lib/exe/fetch.php/download/
DISTNAME= ${PORTNAME}-${DISTVERSION}-minimal
MAINTAINER= bsd@philippost.de
@@ -59,13 +61,14 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-permlib=${LOCALBASE}/lib \
--without-java \
--without-javaview \
+ --without-native \
--without-sympol
CONFIGURE_LOG= build/bundled.log
# Optional features; SoPlex defaults to off due to licencsing and SCIP defaults
# to off due to a dependency on libsoplex.so.
-OPTIONS_DEFINE= LRS NATIVE NORMALIZ OPENMP PPL SCIP SINGULAR SOPLEX TESTS
-OPTIONS_DEFAULT= BLISS LRS NORMALIZ OPENMP PPL SINGULAR
+OPTIONS_DEFINE= LRS NORMALIZ OPENMP OPTIMIZED_CFLAGS PPL SCIP SINGULAR SOPLEX TESTS
+OPTIONS_DEFAULT= BLISS LRS NORMALIZ OPENMP OPTIMIZED_CFLAGS PPL SINGULAR
# Exlude lrslib on i386 and powerpc because it is marked BROKEN for those
# architectures
OPTIONS_EXCLUDE_i386= LRS
@@ -80,7 +83,6 @@ OPTIONS_SINGLE_GRAPH= BLISS NAUTY
BLISS_DESC= Compute graph automorphism groups using bliss
GRAPH_DESC= Graph automorphism groups
LRS_DESC= Convex hull computation and vertex enumeration
-NATIVE_DESC= Build with native optimizations (-march=native)
NAUTY_DESC= Compute graph automorphism groups using nauty
NORMALIZ_DESC= Computations in affine monoids and lattice polytopes
PPL_DESC= Manipulation of convex polyhedra
@@ -103,14 +105,14 @@ LRS_CONFIGURE_ON= --with-lrs=${LOCALBASE} \
LRS_CONFIGURE_OFF= --without-lrs
LRS_LIB_DEPENDS= liblrs.so:math/lrslib
-NATIVE_CONFIGURE_OFF= --without-native
-
NORMALIZ_CONFIGURE_ON= --with-libnormaliz=${LOCALBASE}
NORMALIZ_CONFIGURE_OFF= --without-libnormaliz
NORMALIZ_LIB_DEPENDS= libnormaliz.so:math/libnormaliz
OPENMP_CONFIGURE_OFF= --without-openmp
+OPTIMIZED_CFLAGS_CFLAGS= -O3
+
PPL_CONFIGURE_ON= --with-ppl=${LOCALBASE}
PPL_CONFIGURE_OFF= --without-ppl
PPL_LIB_DEPENDS= libppl.so:devel/ppl
diff --git a/math/polymake/files/patch-support_configure.pl b/math/polymake/files/patch-support_configure.pl
new file mode 100644
index 000000000000..d85e5ec131c7
--- /dev/null
+++ b/math/polymake/files/patch-support_configure.pl
@@ -0,0 +1,11 @@
+--- support/configure.pl.orig 2023-09-02 05:23:02 UTC
++++ support/configure.pl
+@@ -501,7 +501,7 @@ sub parse_command_line {
+ }
+ }
+
+- $CXXOPT =$vars{CXXOPT} // "-O3";
++ $CXXOPT =$vars{CXXOPT} // "";
+ $CXXDEBUG =$vars{CXXDEBUG} // "-g";
+ $CFLAGS =$vars{CFLAGS} // "";
+ $CXXFLAGS =$vars{CXXFLAGS} // $CFLAGS;