aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-30 20:59:57 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 16:13:00 +0000
commit97683e71b1c2b32fe1ef1f9782e16eab3da4c3f3 (patch)
tree03c760c30649135ab9e94eb72312e130d37b0177
parenta5ce289590099e32f52a0dc4e57b27244401ea45 (diff)
downloadports-97683e71b1c2b32fe1ef1f9782e16eab3da4c3f3.tar.gz
ports-97683e71b1c2b32fe1ef1f9782e16eab3da4c3f3.zip
www/angie-module-enhanced-memcached: Angie enhanced memcached dynamic module
Module is to be used to obtain responses from a memcached server. This module is based on the standard memcached module, with some additional features. Base configuration is identical to the standard module. PR: 273462
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-enhanced-memcached/Makefile24
-rw-r--r--www/angie-module-enhanced-memcached/files/pkg-message.in15
-rw-r--r--www/angie-module-enhanced-memcached/pkg-descr3
-rw-r--r--www/angie-module-enhanced-memcached/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 51875e64f8a9..daf1f8c73a59 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -32,6 +32,7 @@
SUBDIR += angie-module-brotli
SUBDIR += angie-module-cache-purge
SUBDIR += angie-module-echo
+ SUBDIR += angie-module-enhanced-memcached
SUBDIR += angie-module-geoip2
SUBDIR += angie-module-image-filter
SUBDIR += angie-module-jwt
diff --git a/www/angie-module-enhanced-memcached/Makefile b/www/angie-module-enhanced-memcached/Makefile
new file mode 100644
index 000000000000..54e3891d54e4
--- /dev/null
+++ b/www/angie-module-enhanced-memcached/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= angie-module-enhanced-memcached
+GH_TUPLE= bpaquet:ngx_http_enhanced_memcached_module:v0.3:module
+
+COMMENT= Angie enhanced memcached dynamic module
+
+LICENSE_FILE= ${WRKSRC_module}/README.markdown
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_enhanced_memcached_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.markdown ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_enhanced_memcached_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_enhanced_memcached_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-enhanced-memcached/files/pkg-message.in b/www/angie-module-enhanced-memcached/files/pkg-message.in
new file mode 100644
index 000000000000..9de0c4b944b0
--- /dev/null
+++ b/www/angie-module-enhanced-memcached/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The enhanced memcached dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_enhanced_memcached_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/bpaquet/ngx_http_enhanced_memcached_module
+EOM
+}
+]
diff --git a/www/angie-module-enhanced-memcached/pkg-descr b/www/angie-module-enhanced-memcached/pkg-descr
new file mode 100644
index 000000000000..dbef896edd8a
--- /dev/null
+++ b/www/angie-module-enhanced-memcached/pkg-descr
@@ -0,0 +1,3 @@
+Module is to be used to obtain responses from a memcached server.
+This module is based on the standard memcached module, with some additional
+features. Base configuration is identical to the standard module.
diff --git a/www/angie-module-enhanced-memcached/pkg-plist b/www/angie-module-enhanced-memcached/pkg-plist
new file mode 100644
index 000000000000..3a1c880f1905
--- /dev/null
+++ b/www/angie-module-enhanced-memcached/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.markdown
+%%MODDIR%%/ngx_http_enhanced_memcached_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_enhanced_memcached_module-debug.so