aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2023-06-25 04:48:38 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2023-06-25 04:48:38 +0000
commit97bb4872ef4e97eb157f8063ddbe4b83f3795ddd (patch)
tree046b71a6ee3e976c8a1f2dbd93d101413e8ce91f
parent0a04ec004e5ad530cde92f437a3cf8f94558478f (diff)
downloadports-97bb4872ef4e97eb157f8063ddbe4b83f3795ddd.tar.gz
ports-97bb4872ef4e97eb157f8063ddbe4b83f3795ddd.zip
net/messagelib: Fix build with llvm 16
Approved by: portmgr (blanket)
-rw-r--r--net/messagelib/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/messagelib/Makefile b/net/messagelib/Makefile
index 2e68778bd2dc..eca7bc2b672b 100644
--- a/net/messagelib/Makefile
+++ b/net/messagelib/Makefile
@@ -42,4 +42,10 @@ OPTIONS_SUB= yes
INOTIFY_DESC= Filesystem alteration notifications using inotify
INOTIFY_LIB_DEPENDS= libinotify.so:devel/libinotify
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CXXFLAGS+= -D_LIBCPP_ENABLE_CXX17_REMOVED_UNARY_BINARY_FUNCTION
+.endif
+
+.include <bsd.port.post.mk>