aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Filla <freebsd@sysctl.cz>2024-02-25 13:56:50 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-02-25 14:04:04 +0000
commit97dc4fa17b1ce14a2490f0761e49ca83b1f630c5 (patch)
tree3b8fa1c33317bd7bad96c2838c2a04638c75c118
parent9c8466566b01cf5b7bce9858c7f7948bd968e410 (diff)
downloadports-97dc4fa17b1ce14a2490f0761e49ca83b1f630c5.tar.gz
ports-97dc4fa17b1ce14a2490f0761e49ca83b1f630c5.zip
devel/raylib: Update to 5.0
While here, - pet Q/A check by using opengl instead of gl in USE_GL - avoid unnecessary removal of bundled glfw as USE_EXTERNAL_GLFW is ON ChangeLog: https://github.com/raysan5/raylib/blob/master/CHANGELOG PR: 277282
-rw-r--r--devel/raylib/Makefile9
-rw-r--r--devel/raylib/distinfo6
-rw-r--r--devel/raylib/files/patch-cmake_LibraryConfigurations.cmake11
-rw-r--r--devel/raylib/files/patch-src_rcore.c15
-rw-r--r--devel/raylib/pkg-plist4
5 files changed, 7 insertions, 38 deletions
diff --git a/devel/raylib/Makefile b/devel/raylib/Makefile
index 1e9b62e50fcf..a80232a59a4c 100644
--- a/devel/raylib/Makefile
+++ b/devel/raylib/Makefile
@@ -1,5 +1,5 @@
PORTNAME= raylib
-DISTVERSION= 4.2.0
+DISTVERSION= 5.0
CATEGORIES= devel education
MAINTAINER= freebsd@sysctl.cz
@@ -9,23 +9,18 @@ WWW= https://www.raylib.com/
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= glfw>=3.3:graphics/glfw
LIB_DEPENDS= libglfw.so:graphics/glfw
USES= cmake gl localbase:ldflags xorg
USE_GITHUB= yes
GH_ACCOUNT= raysan5
-USE_GL= gl glu
+USE_GL= glu opengl
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xcursor xext xi xinerama xrandr xxf86vm
CMAKE_ON= BUILD_SHARED_LIBS USE_EXTERNAL_GLFW
CMAKE_OFF= BUILD_EXAMPLES BUILD_GAMES STATIC
-post-extract:
-# Remove bundled files.
- ${RM} -r ${WRKSRC}/src/external/glfw ${WRKSRC}/src/external/include ${WRKSRC}/src/rglfw.c
-
post-install:
# Install all parts for raylib
${INSTALL_DATA} ${WRKSRC}/src/raylib.h \
diff --git a/devel/raylib/distinfo b/devel/raylib/distinfo
index 93b3aa2f379f..19721f344ef9 100644
--- a/devel/raylib/distinfo
+++ b/devel/raylib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1664546814
-SHA256 (raysan5-raylib-4.2.0_GH0.tar.gz) = 676217604a5830cb4aa31e0ede0e4233c942e2fc5c206691bded58ebcd82a590
-SIZE (raysan5-raylib-4.2.0_GH0.tar.gz) = 31301099
+TIMESTAMP = 1708772122
+SHA256 (raysan5-raylib-5.0_GH0.tar.gz) = 98f049b9ea2a9c40a14e4e543eeea1a7ec3090ebdcd329c4ca2cf98bc9793482
+SIZE (raysan5-raylib-5.0_GH0.tar.gz) = 32701105
diff --git a/devel/raylib/files/patch-cmake_LibraryConfigurations.cmake b/devel/raylib/files/patch-cmake_LibraryConfigurations.cmake
deleted file mode 100644
index 451cdb913bdb..000000000000
--- a/devel/raylib/files/patch-cmake_LibraryConfigurations.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/LibraryConfigurations.cmake.orig 2022-09-30 14:46:52 UTC
-+++ cmake/LibraryConfigurations.cmake
-@@ -27,7 +27,7 @@ if (${PLATFORM} MATCHES "Desktop")
- find_library(OSS_LIBRARY ossaudio)
- endif ()
-
-- set(LIBS_PRIVATE m atomic pthread ${OPENGL_LIBRARIES} ${OSS_LIBRARY})
-+ set(LIBS_PRIVATE m pthread ${OPENGL_LIBRARIES} ${OSS_LIBRARY})
-
- if (USE_AUDIO)
- set(LIBS_PRIVATE ${LIBS_PRIVATE} dl)
diff --git a/devel/raylib/files/patch-src_rcore.c b/devel/raylib/files/patch-src_rcore.c
deleted file mode 100644
index 3ff32dcde4f8..000000000000
--- a/devel/raylib/files/patch-src_rcore.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/rcore.c.orig 2022-09-30 14:25:29 UTC
-+++ src/rcore.c
-@@ -239,6 +239,12 @@
- #endif
- #endif
-
-+// TODO: HACK: Added flag if not provided by GLFW when using external library
-+// Latest GLFW release (GLFW 3.3.8) does not implement this flag, it was added for 3.4.0-dev
-+#if !defined(GLFW_MOUSE_PASSTHROUGH)
-+ #define GLFW_MOUSE_PASSTHROUGH 0x0002000D
-+#endif
-+
- #if defined(PLATFORM_ANDROID)
- //#include <android/sensor.h> // Required for: Android sensors functions (accelerometer, gyroscope, light...)
- #include <android/window.h> // Required for: AWINDOW_FLAG_FULLSCREEN definition and others
diff --git a/devel/raylib/pkg-plist b/devel/raylib/pkg-plist
index 04ea33cb9d30..4a5864329127 100644
--- a/devel/raylib/pkg-plist
+++ b/devel/raylib/pkg-plist
@@ -4,6 +4,6 @@ include/rlgl.h
lib/cmake/raylib/raylib-config-version.cmake
lib/cmake/raylib/raylib-config.cmake
lib/libraylib.so
-lib/libraylib.so.4.2.0
-lib/libraylib.so.420
+lib/libraylib.so.4.5.0
+lib/libraylib.so.450
libdata/pkgconfig/raylib.pc