aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-12 03:57:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-12 03:58:50 +0000
commit981a41b93b1333b036c160037f60db69bd08e5d5 (patch)
treee80dcb3fd159493c5e229329ce52a955117d43e7
parentb587a873862fec7fd1cfa7d0651fd2b1c6ec00d7 (diff)
downloadports-981a41b93b1333b036c160037f60db69bd08e5d5.tar.gz
ports-981a41b93b1333b036c160037f60db69bd08e5d5.zip
audio/spectmorph: Remove 'register' keywords instead of having USE_STDCXX=c++17
Reported by: fallout (cherry picked from commit 09052707e3a262826072c2a1e31e2442c35a8d94)
-rw-r--r--audio/spectmorph/Makefile1
-rw-r--r--audio/spectmorph/files/patch-lib_smmath.hh23
2 files changed, 23 insertions, 1 deletions
diff --git a/audio/spectmorph/Makefile b/audio/spectmorph/Makefile
index 3ead26e0b97c..52864fa7dc7c 100644
--- a/audio/spectmorph/Makefile
+++ b/audio/spectmorph/Makefile
@@ -25,7 +25,6 @@ USE_GNOME= cairo glib20
USE_GL= gl
USE_XORG= x11
USE_LDCONFIG= yes
-USE_CXXSTD= c++14 # fix compilation failure on 14: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister]
SHEBANG_FILES= tools/sminstbuilder.in
diff --git a/audio/spectmorph/files/patch-lib_smmath.hh b/audio/spectmorph/files/patch-lib_smmath.hh
new file mode 100644
index 000000000000..964a0b94fdcb
--- /dev/null
+++ b/audio/spectmorph/files/patch-lib_smmath.hh
@@ -0,0 +1,23 @@
+- fix compilation failure on 14: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister]
+- see https://github.com/swesterfeld/spectmorph/issues/23
+
+--- lib/smmath.hh.orig 2023-07-12 03:47:47 UTC
++++ lib/smmath.hh
+@@ -431,7 +431,7 @@ double db_from_factor (double factor, double min_dB);
+
+ #if defined (__i386__) && defined (__GNUC__)
+ static inline int G_GNUC_CONST
+-sm_ftoi (register float f)
++sm_ftoi (float f)
+ {
+ int r;
+
+@@ -441,7 +441,7 @@ sm_ftoi (register float f)
+ return r;
+ }
+ static inline int G_GNUC_CONST
+-sm_dtoi (register double f)
++sm_dtoi (double f)
+ {
+ int r;
+