aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:46:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:51 +0000
commit9823fb61f59927e7c055b87c02a784359d883006 (patch)
tree6a487a0197e542543a6ced0f08fc4c5c7f418bcd
parentfe39695b61f7d43a5423ffdb9f27a9f84c8664f6 (diff)
downloadports-9823fb61f59927e7c055b87c02a784359d883006.tar.gz
ports-9823fb61f59927e7c055b87c02a784359d883006.zip
devel/py-installer03: Add py-installer03 0.3.0 (copied from py-installer)
- Add PORTSCOUT
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-installer03/Makefile23
-rw-r--r--devel/py-installer03/distinfo3
-rw-r--r--devel/py-installer03/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 12dd3d898fa5..918fd1ddcab7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4638,6 +4638,7 @@
SUBDIR += py-inifile
SUBDIR += py-iniparse
SUBDIR += py-installer
+ SUBDIR += py-installer03
SUBDIR += py-intbitset
SUBDIR += py-intelhex
SUBDIR += py-intervals
diff --git a/devel/py-installer03/Makefile b/devel/py-installer03/Makefile
new file mode 100644
index 000000000000..1d01c873ba2d
--- /dev/null
+++ b/devel/py-installer03/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= installer
+PORTVERSION= 0.3.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 03
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for installing Python wheels
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:0\.3\.
+
+.include <bsd.port.mk>
diff --git a/devel/py-installer03/distinfo b/devel/py-installer03/distinfo
new file mode 100644
index 000000000000..7ae5ead6924e
--- /dev/null
+++ b/devel/py-installer03/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634111752
+SHA256 (installer-0.3.0.tar.gz) = e7dc5ec8b737fe3fa7c1872a6ebe120d7abc7cf780aa39af669c382a0fcb6de7
+SIZE (installer-0.3.0.tar.gz) = 467762
diff --git a/devel/py-installer03/pkg-descr b/devel/py-installer03/pkg-descr
new file mode 100644
index 000000000000..7baa82b559c4
--- /dev/null
+++ b/devel/py-installer03/pkg-descr
@@ -0,0 +1,10 @@
+This is a low-level library for installing a Python package from a wheel
+distribution. It provides basic functionality and abstractions for handling
+wheels and installing packages from wheels.
+
+- Logic for "unpacking" a wheel (i.e. installation).
+- Abstractions for various parts of the unpacking process.
+- Extensible simple implementations of the abstractions.
+- Platform-independent Python script wrapper generation.
+
+WWW: https://github.com/pradyunsg/installer