aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-04-11 21:36:07 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-04-11 21:36:38 +0000
commit982e8c1be378cd948caf6161b507eb5cf1bb9a67 (patch)
treec6e5f8a4c56393faff0639f3e2991d134a61e091
parentf55049ff209e2b0be83c36d88687862b5cc94512 (diff)
downloadports-982e8c1be378cd948caf6161b507eb5cf1bb9a67.tar.gz
ports-982e8c1be378cd948caf6161b507eb5cf1bb9a67.zip
security/gnome-ssh-askpass: Update version 8.2p1=>9.7p1
-rw-r--r--security/gnome-ssh-askpass/Makefile2
-rw-r--r--security/gnome-ssh-askpass/distinfo6
-rw-r--r--security/gnome-ssh-askpass/files/patch-contrib_gnome-ssh-askpass2.c11
3 files changed, 10 insertions, 9 deletions
diff --git a/security/gnome-ssh-askpass/Makefile b/security/gnome-ssh-askpass/Makefile
index db57acae9d62..7989db33ca64 100644
--- a/security/gnome-ssh-askpass/Makefile
+++ b/security/gnome-ssh-askpass/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gnome-ssh-askpass
-PORTVERSION= 8.2p1
+PORTVERSION= 9.7p1
CATEGORIES= security gnome
MASTER_SITES= OPENBSD/OpenSSH/portable/
DISTNAME= openssh-${PORTVERSION}
diff --git a/security/gnome-ssh-askpass/distinfo b/security/gnome-ssh-askpass/distinfo
index 84ecea44197b..133bdd8d9254 100644
--- a/security/gnome-ssh-askpass/distinfo
+++ b/security/gnome-ssh-askpass/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1712763424
-SHA256 (openssh-8.2p1.tar.gz) = 43925151e6cf6cee1450190c0e9af4dc36b41c12737619edff8bcebdff64e671
-SIZE (openssh-8.2p1.tar.gz) = 1701197
+TIMESTAMP = 1712871104
+SHA256 (openssh-9.7p1.tar.gz) = 490426f766d82a2763fcacd8d83ea3d70798750c7bd2aff2e57dc5660f773ffd
+SIZE (openssh-9.7p1.tar.gz) = 1848766
diff --git a/security/gnome-ssh-askpass/files/patch-contrib_gnome-ssh-askpass2.c b/security/gnome-ssh-askpass/files/patch-contrib_gnome-ssh-askpass2.c
index 03063378a484..9df904e748a8 100644
--- a/security/gnome-ssh-askpass/files/patch-contrib_gnome-ssh-askpass2.c
+++ b/security/gnome-ssh-askpass/files/patch-contrib_gnome-ssh-askpass2.c
@@ -1,6 +1,6 @@
---- contrib/gnome-ssh-askpass2.c.orig 2020-02-14 00:40:54 UTC
+--- contrib/gnome-ssh-askpass2.c.orig 2024-03-11 05:20:49 UTC
+++ contrib/gnome-ssh-askpass2.c
-@@ -90,13 +90,14 @@ passphrase_dialog(char *message, int prompt_type)
+@@ -151,7 +151,7 @@ passphrase_dialog(char *message, int prompt_type)
{
const char *failed;
char *passphrase, *local;
@@ -9,14 +9,15 @@
int buttons, default_response;
GtkWidget *parent_window, *dialog, *entry;
GdkGrabStatus status;
+@@ -160,6 +160,7 @@ passphrase_dialog(char *message, int prompt_type)
grab_server = (getenv("GNOME_SSH_ASKPASS_GRAB_SERVER") != NULL);
grab_pointer = (getenv("GNOME_SSH_ASKPASS_GRAB_POINTER") != NULL);
+ grab_keyboard = (getenv("GNOME_SSH_ASKPASS_GRAB_KEYBOARD") != NULL);
grab_tries = 0;
- /* Create an invisible parent window so that GtkDialog doesn't
-@@ -156,18 +157,20 @@ passphrase_dialog(char *message, int prompt_type)
+ fg_set = parse_env_hex_color("GNOME_SSH_ASKPASS_FG_COLOR", &fg);
+@@ -243,18 +244,20 @@ passphrase_dialog(char *message, int prompt_type)
}
}
}
@@ -49,7 +50,7 @@
if (grab_server) {
gdk_x11_grab_server();
}
-@@ -179,7 +182,8 @@ passphrase_dialog(char *message, int prompt_type)
+@@ -266,7 +269,8 @@ passphrase_dialog(char *message, int prompt_type)
XUngrabServer(gdk_x11_get_default_xdisplay());
if (grab_pointer)
gdk_pointer_ungrab(GDK_CURRENT_TIME);