aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-06-29 07:32:55 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-06-29 07:41:49 +0000
commit987fd995a979e7dd62be780aa3fb665a874d1b28 (patch)
treeb3d332cacd079e47ad032fc0e1af7fc9a63fc5e1
parentae39d556b53d577b78431b000a1a38ba86557154 (diff)
downloadports-987fd995a979e7dd62be780aa3fb665a874d1b28.tar.gz
ports-987fd995a979e7dd62be780aa3fb665a874d1b28.zip
devel/qt6-base: Fix configure on live systems
Configure will fail on live systems that have sysutils/lttng-ust installed. Disable detection of LTTngUST to remedy this in the meantime. I don't think we really need this, though, and it's probably best not to rely on an unmaintained port. PR: 280007 Reported by: O. Hartmann <ohartmann@walstatt.org>
-rw-r--r--devel/qt6-base/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/qt6-base/Makefile b/devel/qt6-base/Makefile
index 3f62825bb99f..dd0c5ef4a01e 100644
--- a/devel/qt6-base/Makefile
+++ b/devel/qt6-base/Makefile
@@ -41,7 +41,8 @@ USE_GL= egl opengl
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 pango
USE_LOCALE= C.UTF-8
CMAKE_ARGS= -DOPENSSL_ROOT_DIR="${OPENSSLBASE}"
-CMAKE_ON= QT_AVOID_CMAKE_ARCHIVING_API \
+CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_LTTngUST \
+ QT_AVOID_CMAKE_ARCHIVING_API \
QT_FIND_ALL_PACKAGES_ALWAYS \
QT_FEATURE_openssl_linked
CMAKE_OFF= QT_FEATURE_eglfs \