aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-02-10 09:20:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-02-10 09:21:11 +0000
commit98813d7cc5906863d6f2624de70507c7f7264ec1 (patch)
tree570f4ec5af69af440052daa8e7e3bf24c89a3702
parent1afd5dd5054105cae189aa6a1b596936b2067d62 (diff)
downloadports-98813d7cc5906863d6f2624de70507c7f7264ec1.tar.gz
ports-98813d7cc5906863d6f2624de70507c7f7264ec1.zip
math/pffft: Fix build on i386
Reported by: fallout
-rw-r--r--math/pffft/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/pffft/Makefile b/math/pffft/Makefile
index 1ed5f334b7d8..2835b89796ef 100644
--- a/math/pffft/Makefile
+++ b/math/pffft/Makefile
@@ -17,9 +17,15 @@ GH_TAGNAME= 9603871
CMAKE_ON= BUILD_SHARED_LIBS INSTALL_PFDSP INSTALL_PFFASTCONV
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+CXXFLAGS+= -msse2 # fixes error: always_inline function '_mm_unpacklo_ps' requires target feature 'sse', but would be inlined into function 'pffft_zreorder' that is compiled without support for 'sse'
+.endif
+
post-install: # move headers into a dedicated directory
cd ${STAGEDIR}${PREFIX} && \
${MKDIR} include/${PORTNAME} && \
${MV} include/*.h include/*.hpp include/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>