aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLexi Winter <lexi@le-fay.org>2023-12-27 12:17:18 +0000
committerJoel Bodenmann <jbo@FreeBSD.org>2024-02-04 20:13:19 +0000
commit98816358fdd22f1d58a71b25f0b357314901a022 (patch)
tree7747cba9acf23bb63345ef8eff183f58828849cd
parent92b051a2909f68d74d1bb641a08bdc09365e5083 (diff)
downloadports-98816358fdd22f1d58a71b25f0b357314901a022.tar.gz
ports-98816358fdd22f1d58a71b25f0b357314901a022.zip
multimedia/mediaelch: New port
Desktop utility to manage metadata and artwork for Kodi and Jellyfin. PR: 275962 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D43477
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mediaelch/Makefile42
-rw-r--r--multimedia/mediaelch/distinfo3
-rw-r--r--multimedia/mediaelch/pkg-descr5
4 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 1a5e107af707..f0141502a0b4 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -214,6 +214,7 @@
SUBDIR += lsdvd
SUBDIR += m2vrequantiser
SUBDIR += makemkv
+ SUBDIR += mediaelch
SUBDIR += mediainfo
SUBDIR += mencoder
SUBDIR += minisatip
diff --git a/multimedia/mediaelch/Makefile b/multimedia/mediaelch/Makefile
new file mode 100644
index 000000000000..979120f48e62
--- /dev/null
+++ b/multimedia/mediaelch/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= mediaelch
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.10.6
+CATEGORIES= multimedia
+PKGNAMESUFFIX= -${FLAVOR}
+
+MAINTAINER= lexi.freebsd@le-fay.org
+COMMENT= Desktop utility to manage metadata and artwork for Kodi and Jellyfin
+WWW= https://www.mediaelch.de/mediaelch/
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libmediainfo.so:multimedia/libmediainfo \
+ libcurl.so:ftp/curl \
+ libquazip1-${FLAVOR}.so:archivers/quazip@${FLAVOR}
+
+FLAVORS= qt6 qt5
+FLAVOR?= qt6
+
+USES= cmake gl localbase:ldflags qt:${FLAVOR:S/qt//}
+
+USE_GITHUB= yes
+GH_ACCOUNT= Komet
+GH_PROJECT= MediaElch
+
+USE_GL= opengl
+
+_USE_QT_qt5= buildtools:build qmake:build linguisttools:build \
+ concurrent core gui multimedia network opengl qmake sql svg \
+ widgets xml
+_USE_QT_qt6= 5compat base multimedia svg tools
+USE_QT= ${_USE_QT_${FLAVOR}}
+
+CMAKE_ON= USE_EXTERN_QUAZIP MEDIAELCH_FORCE_QT${FLAVOR:S/qt//}
+
+PLIST_FILES= bin/MediaElch \
+ share/applications/MediaElch.desktop \
+ share/metainfo/com.kvibes.MediaElch.metainfo.xml \
+ share/pixmaps/MediaElch.png
+
+.include <bsd.port.mk>
diff --git a/multimedia/mediaelch/distinfo b/multimedia/mediaelch/distinfo
new file mode 100644
index 000000000000..82413e3359cd
--- /dev/null
+++ b/multimedia/mediaelch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1705330582
+SHA256 (Komet-MediaElch-v2.10.6_GH0.tar.gz) = c37464e4cf956e9abec14126eb681633988f31ba2b0f937817c7829c25737e22
+SIZE (Komet-MediaElch-v2.10.6_GH0.tar.gz) = 3300733
diff --git a/multimedia/mediaelch/pkg-descr b/multimedia/mediaelch/pkg-descr
new file mode 100644
index 000000000000..f624c5472ee0
--- /dev/null
+++ b/multimedia/mediaelch/pkg-descr
@@ -0,0 +1,5 @@
+MediaElch is a desktop media metadata manager for Kodi and Jellyfin.
+
+It can automatically download information about movies, TV shows and music,
+including artwork, and create ".nfo" files which are used by the Kodi/Jellyfin
+user interface.