aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-11-25 12:54:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-11-27 10:01:12 +0000
commit98949a34f45e194aa83752ebf4bca6fa3fa38478 (patch)
tree524d4c301c4fac34c938f66c565c4d5ab56ca8da
parent0d170e0b22b9bb0ddadabbc2a08cd6b3fc9d8201 (diff)
downloadports-98949a34f45e194aa83752ebf4bca6fa3fa38478.tar.gz
ports-98949a34f45e194aa83752ebf4bca6fa3fa38478.zip
graphics/mesa-dri: enable codecs for Vulkan Video after 29d855b6f775
Mesa 23 enabled Vulkan Video itself but all codecs are disabled by default due to patents. Copy -Dvideo-codecs from mesa-gallium-va to avoid the following error: [ffmpeg/video] h264: Device does not support decoding h264! $ vulkaninfo | fgrep decode <empty> $ export ANV_VIDEO_DECODE=1 RADV_PERFTEST=video_decode $ vulkaninfo | fgrep decode VK_KHR_video_decode_queue : extension revision 7 $ pkg upgrade mesa-dri $ vulkaninfo | fgrep decode VK_KHR_video_decode_h264 : extension revision 8 VK_KHR_video_decode_queue : extension revision 7 PR: 275360 Approved by: manu
-rw-r--r--graphics/mesa-dri/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index e309b1adf75f..96b650db6d07 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mesa-dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
@@ -73,6 +73,9 @@ MESON_ARGS+= -Dgallium-drivers="${GALLIUM_DRIVERS:ts,:tl}" \
-Dvulkan-drivers="${VULKAN_DRIVERS:ts,:tl}" \
-Dplatforms="${MESA_PLATFORMS:ts,:tl}"
+# Vulkan Video extensions (keep in sync with mesa-gallium-va)
+MESON_ARGS+= -Dvideo-codecs="vc1dec,h264dec,h264enc,h265dec,h265enc"
+
# Disable some options
MESON_ARGS+= -Dandroid-libbacktrace=disabled \
-Dgallium-xa=disabled \