aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-17 06:36:19 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-03-17 06:37:07 +0000
commit98a406d77e3a56c54ac51e1d128ad375e2a2d133 (patch)
tree0a986180ab6c8da8e0ec5bb916843cfa93be2a89
parent1e7e52e029c8f5ffc38448ae46bc804a16fe6906 (diff)
downloadports-98a406d77e3a56c54ac51e1d128ad375e2a2d133.tar.gz
ports-98a406d77e3a56c54ac51e1d128ad375e2a2d133.zip
security/py-netbox-secretstore: Fix missing database migrations
* Backport a patch that fixes missing database migrations. * Bump PORTREVISION due changed package. MFH: No (not applicable for netbox-secretstore < 1.4.0)
-rw-r--r--security/py-netbox-secretstore/Makefile1
-rw-r--r--security/py-netbox-secretstore/files/patch-netbox__secretstore_migrations_0006__alter__secret__custom__field__data__and__more.py35
2 files changed, 36 insertions, 0 deletions
diff --git a/security/py-netbox-secretstore/Makefile b/security/py-netbox-secretstore/Makefile
index 1e673017fbd3..6aeed0a86090 100644
--- a/security/py-netbox-secretstore/Makefile
+++ b/security/py-netbox-secretstore/Makefile
@@ -1,5 +1,6 @@
PORTNAME= netbox-secretstore
DISTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-netbox-secretstore/files/patch-netbox__secretstore_migrations_0006__alter__secret__custom__field__data__and__more.py b/security/py-netbox-secretstore/files/patch-netbox__secretstore_migrations_0006__alter__secret__custom__field__data__and__more.py
new file mode 100644
index 000000000000..ba6e41dd0b31
--- /dev/null
+++ b/security/py-netbox-secretstore/files/patch-netbox__secretstore_migrations_0006__alter__secret__custom__field__data__and__more.py
@@ -0,0 +1,35 @@
+From: Daniel Sheppard <dans@dansheps.com>
+Date: Tue, 24 Jan 2023 13:51:57 -0600
+Subject: [PATCH] Update for missing migrations
+
+Obtained from:
+
+https://github.com/DanSheps/netbox-secretstore/commit/9c3f69e5af6f5e8d6af11f5c8ea41433ef51145c
+
+--- netbox_secretstore/migrations/0006_alter_secret_custom_field_data_and_more.py.orig 2023-03-16 06:29:56 UTC
++++ netbox_secretstore/migrations/0006_alter_secret_custom_field_data_and_more.py
+@@ -0,0 +1,24 @@
++# Generated by Django 4.1.4 on 2023-01-24 19:50
++
++from django.db import migrations, models
++import utilities.json
++
++
++class Migration(migrations.Migration):
++
++ dependencies = [
++ ('netbox_secretstore', '0005_alter_secret_created_alter_secret_id_and_more'),
++ ]
++
++ operations = [
++ migrations.AlterField(
++ model_name='secret',
++ name='custom_field_data',
++ field=models.JSONField(blank=True, default=dict, encoder=utilities.json.CustomFieldJSONEncoder),
++ ),
++ migrations.AlterField(
++ model_name='secretrole',
++ name='custom_field_data',
++ field=models.JSONField(blank=True, default=dict, encoder=utilities.json.CustomFieldJSONEncoder),
++ ),
++ ]