aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 15:33:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 15:38:53 +0000
commit98a73f0542288bee927bb6512b36a6f8b0672db9 (patch)
tree5f37b00cda795ca074222b7658f1941df317f020
parent5858ed1e9874df4bdbb157a8ea33a4a5e3d93f48 (diff)
downloadports-98a73f0542288bee927bb6512b36a6f8b0672db9.tar.gz
ports-98a73f0542288bee927bb6512b36a6f8b0672db9.zip
games/falconseye: Fix build with llvm15
- Pet portclippy - Utilize USES=localbase - Replace deprecated @unexec - Fix missing deps
-rw-r--r--games/falconseye/Makefile31
-rw-r--r--games/falconseye/pkg-plist3
2 files changed, 22 insertions, 12 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index a1b5c240d5d5..f23a463f85ce 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -11,19 +11,30 @@ WWW= http://falconseye.sourceforge.net/
RUN_DEPENDS= timidity:audio/timidity
-USES= cpe ncurses perl5 sdl xorg zip
+USES= cpe localbase ncurses perl5 sdl xorg zip
CPE_VENDOR= ${PORTNAME}_project
-DATADIR= ${PREFIX}/share/falconseyedir
-MAKE_ENV= NHDIR="${DATADIR}" NETHACKCONFIG="${NETHACKCONFIG}"
-MAKE_ARGS= WINTTYLIB="-lncurses"
-NETHACKCONFIG= ${FILESDIR}/x-config
-USE_SDL= sdl
USE_PERL5= build
-USE_XORG= x11 xpm xaw
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11 \
+USE_SDL= sdl
+USE_XORG= x11 xaw xext xmu xpm xt
+
+MAKE_ARGS= WINTTYLIB="-lncurses"
+MAKE_ENV= NHDIR="${DATADIR}" NETHACKCONFIG="${NETHACKCONFIG}"
+MAKE_JOBS_UNSAFE= yes
+
+CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11 \
-Wno-return-type
+
+DATADIR= ${PREFIX}/share/falconseyedir
+
NO_WRKSUBDIR= yes
-MAKE_JOBS_UNSAFE= yes
+
+NETHACKCONFIG= ${FILESDIR}/x-config
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
post-patch:
@${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
@@ -48,4 +59,4 @@ post-install:
${TOUCH} ${STAGEDIR}${DATADIR}/logfile ${STAGEDIR}${DATADIR}/perm \
${STAGEDIR}${DATADIR}/record
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/falconseye/pkg-plist b/games/falconseye/pkg-plist
index 62e9d11c3328..2033d9009c68 100644
--- a/games/falconseye/pkg-plist
+++ b/games/falconseye/pkg-plist
@@ -262,5 +262,4 @@ man/man6/frecover.6.gz
%%DATADIR%%/wizard3.lev
%%DATADIR%%/wizhelp
@dir(,games,575) %%DATADIR%%/save
-@unexec rm -f %D/%%DATADIR%%/logfile %D/%%DATADIR%%/perm %D/%%DATADIR%%/record %D/%%DATADIR%%/jtp_log.txt
-@unexec rm -rf %D/%%DATADIR%%/save
+@postunexec rm -f %D/%%DATADIR%%/logfile %D/%%DATADIR%%/perm %D/%%DATADIR%%/record %D/%%DATADIR%%/jtp_log.txt