aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrond Endrestøl <Trond.Endrestol@ximalas.info>2021-11-08 13:34:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-11-08 13:36:58 +0000
commit98b8e8b444dc2e7c37266205af6225034e20e560 (patch)
treefd44c079d31d19e50bd18d46bda40ed05f20f404
parent7a64dcaea7bcfe0066cba81016a06ef91a1b4027 (diff)
downloadports-98b8e8b444dc2e7c37266205af6225034e20e560.tar.gz
ports-98b8e8b444dc2e7c37266205af6225034e20e560.zip
Mk/bsd.port.mk: configurable delay identify-install-conflicts
Instead of hardcoding the 10s delay for the conflicts warning, add a new variable CONFLICT_WARNING_WAIT the same way we have WARNING_WAIT and DEV_WARNING_WAIT PR: 248548
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 40144769d967..317b65f748e2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3359,6 +3359,7 @@ check-build-conflicts:
.endif
.if !target(identify-install-conflicts)
+CONFLICT_WARNING_WAIT?= 10
identify-install-conflicts:
.if ( defined(CONFLICTS) || defined(CONFLICTS_INSTALL) ) && !defined(DISABLE_CONFLICTS)
@conflicts_with=$$( \
@@ -3377,7 +3378,7 @@ identify-install-conflicts:
${ECHO_MSG}; \
${ECHO_MSG} " They install files into the same place."; \
${ECHO_MSG} " You may want to stop build with Ctrl + C."; \
- sleep 10; \
+ sleep ${CONFLICT_WARNING_WAIT}; \
fi
.endif
.endif