aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:15:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:30:10 +0000
commit994eaf68af4fcc07d0c9a8ac93290eb1acaadb3f (patch)
treec8137a730bc8498aba4558968e3b889a03251d41
parent91bb5e97bf3716e47c55f40f50e45ba7adbac54e (diff)
downloadports-994eaf68af4fcc07d0c9a8ac93290eb1acaadb3f.tar.gz
ports-994eaf68af4fcc07d0c9a8ac93290eb1acaadb3f.zip
audio/py-speechrecognition: Update to 3.10.0
-rw-r--r--audio/py-speechrecognition/Makefile4
-rw-r--r--audio/py-speechrecognition/distinfo6
-rw-r--r--audio/py-speechrecognition/files/patch-setup.py9
3 files changed, 9 insertions, 10 deletions
diff --git a/audio/py-speechrecognition/Makefile b/audio/py-speechrecognition/Makefile
index 18dc914bd995..28199e6f4546 100644
--- a/audio/py-speechrecognition/Makefile
+++ b/audio/py-speechrecognition/Makefile
@@ -1,5 +1,5 @@
PORTNAME= speechrecognition
-PORTVERSION= 3.9.0
+PORTVERSION= 3.10.0
MASTER_SITES= PYPI
CATEGORIES= audio python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ RUN_DEPENDS= flac:audio/flac \
${PYTHON_PKGNAMEPREFIX}pyaudio>=0.2.11:audio/py-pyaudio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.26.0:www/py-requests@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.8+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/audio/py-speechrecognition/distinfo b/audio/py-speechrecognition/distinfo
index 7edf222045ae..102c723078ca 100644
--- a/audio/py-speechrecognition/distinfo
+++ b/audio/py-speechrecognition/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674065871
-SHA256 (SpeechRecognition-3.9.0.tar.gz) = a2f992acda6314a3fa574bf84c2e075ce75f2b4c143b4435d7cbc98f66565ee7
-SIZE (SpeechRecognition-3.9.0.tar.gz) = 32851748
+TIMESTAMP = 1679498634
+SHA256 (SpeechRecognition-3.10.0.tar.gz) = 14131155e8a8ba00ead1b7b9b1a2fa71c845e4db5f9a5f66a33a1bd6c55c6c35
+SIZE (SpeechRecognition-3.10.0.tar.gz) = 32847550
diff --git a/audio/py-speechrecognition/files/patch-setup.py b/audio/py-speechrecognition/files/patch-setup.py
index 3e6a634ebe19..ed1c93d55aa8 100644
--- a/audio/py-speechrecognition/files/patch-setup.py
+++ b/audio/py-speechrecognition/files/patch-setup.py
@@ -1,10 +1,9 @@
---- setup.py.orig 2017-10-14 15:52:28 UTC
+--- setup.py.orig 2023-03-13 12:15:10 UTC
+++ setup.py
-@@ -14,34 +14,11 @@ if sys.version_info < (2, 6):
- print("THIS MODULE REQUIRES PYTHON 2.6, 2.7, OR 3.3+. YOU ARE CURRENTLY USING PYTHON {0}".format(sys.version))
- sys.exit(1)
+@@ -10,33 +10,11 @@ from distutils import log
+
+ import speech_recognition
--
-FILES_TO_MARK_EXECUTABLE = ["flac-linux-x86", "flac-linux-x86_64", "flac-mac", "flac-win32.exe"]
-
-