aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:39:04 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:42:09 +0000
commit99db9d6ed73749c31392037978b3c6be7b9400a7 (patch)
treef1552f9b679de854597ebbbc43ee3cd037fcbc52
parente1479964ed3561ef03024cddf6e9a2f584764450 (diff)
downloadports-99db9d6ed73749c31392037978b3c6be7b9400a7.tar.gz
ports-99db9d6ed73749c31392037978b3c6be7b9400a7.zip
math/py-timple: Allow build with newer py-setuptools
/usr/local/lib/python3.9/site-packages/setuptools/dist.py:745: SetuptoolsDeprecationWarning: Invalid dash-separated options !! ******************************************************************************** Usage of dash-separated 'home-page' will not be supported in future versions. Please use the underscore name 'home_page' instead. By 2023-Sep-26, you need to update your project and remove deprecated calls or your builds will no longer be supported. See https://setuptools.pypa.io/en/latest/userguide/declarative_config.html for details. ******************************************************************************** !! opt = self.warn_dash_deprecation(opt, section) /usr/local/lib/python3.9/site-packages/setuptools/dist.py:745: SetuptoolsDeprecationWarning: Invalid dash-separated options !! ******************************************************************************** Usage of dash-separated 'long-description' will not be supported in future versions. Please use the underscore name 'long_description' instead. By 2023-Sep-26, you need to update your project and remove deprecated calls or your builds will no longer be supported. See https://setuptools.pypa.io/en/latest/userguide/declarative_config.html for details. ******************************************************************************** !! opt = self.warn_dash_deprecation(opt, section) Traceback (most recent call last): File "<string>", line 1, in <module> File "setup.py", line 3, in <module> setuptools.setup() File "/usr/local/lib/python3.9/site-packages/setuptools/__init__.py", line 107, in setup return distutils.core.setup(**attrs) File "/usr/local/lib/python3.9/site-packages/setuptools/_distutils/core.py", line 159, in setup dist.parse_config_files() File "/usr/local/lib/python3.9/site-packages/setuptools/dist.py", line 894, in parse_config_files setupcfg.parse_configuration( File "/usr/local/lib/python3.9/site-packages/setuptools/config/setupcfg.py", line 177, in parse_configuration options.parse() File "/usr/local/lib/python3.9/site-packages/setuptools/config/setupcfg.py", line 500, in parse section_parser_method(section_options) File "/usr/local/lib/python3.9/site-packages/setuptools/config/setupcfg.py", line 475, in parse_section self[name] = value File "/usr/local/lib/python3.9/site-packages/setuptools/config/setupcfg.py", line 293, in __setitem__ parsed = self.parsers.get(option_name, lambda x: x)(value) File "/usr/local/lib/python3.9/site-packages/setuptools/_vendor/packaging/specifiers.py", line 714, in __init__ parsed.add(Specifier(specifier)) File "/usr/local/lib/python3.9/site-packages/setuptools/_vendor/packaging/specifiers.py", line 245, in __init__ raise InvalidSpecifier(f"Invalid specifier: '{spec}'") setuptools.extern.packaging.specifiers.InvalidSpecifier: Invalid specifier: '>= 3.*' *** Error code 1 Approved by: portmgr (blanket) With hat: python
-rw-r--r--math/py-timple/files/patch-setup.cfg21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/py-timple/files/patch-setup.cfg b/math/py-timple/files/patch-setup.cfg
new file mode 100644
index 000000000000..1881b5a1fd7c
--- /dev/null
+++ b/math/py-timple/files/patch-setup.cfg
@@ -0,0 +1,21 @@
+--- setup.cfg.orig 2021-11-18 17:41:37 UTC
++++ setup.cfg
+@@ -5,15 +5,15 @@ license = MIT
+ license_files = LICENSE.rst
+ author = Oehrly
+ author_email = oehrly@mailbox.org
+-home-page = https://github.com/theOehrly/Timple
++home_page = https://github.com/theOehrly/Timple
+ description = Extended functionality for plotting timedelta-like values with Matplotlib
+-long-description = file: README.md
++long_description = file: README.md
+ long_description_content_type = text/markdown
+
+ [options]
+ zip_safe = False
+ packages = timple
+-python_requires = >= 3.*
++python_requires = >= 3.0
+ install_requires =
+ numpy
+ matplotlib