aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:00:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:21:34 +0000
commit9a0b8ca57d23a219954c64919f9891e426e402cb (patch)
treed1c47779645b89f53d986c6794b446e6a3ddae1b
parent71969abca150e47bdf5628e870293823420a5f13 (diff)
downloadports-9a0b8ca57d23a219954c64919f9891e426e402cb.tar.gz
ports-9a0b8ca57d23a219954c64919f9891e426e402cb.zip
finance/py-yfinance: Update to 0.2.40
-rw-r--r--finance/py-yfinance/Makefile7
-rw-r--r--finance/py-yfinance/distinfo6
-rw-r--r--finance/py-yfinance/files/patch-setup.py8
3 files changed, 10 insertions, 11 deletions
diff --git a/finance/py-yfinance/Makefile b/finance/py-yfinance/Makefile
index 8acaa389b5c3..20e5782f5935 100644
--- a/finance/py-yfinance/Makefile
+++ b/finance/py-yfinance/Makefile
@@ -1,6 +1,5 @@
PORTNAME= yfinance
-PORTVERSION= 0.2.38
-PORTREVISION= 1
+PORTVERSION= 0.2.40
CATEGORIES= finance python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,8 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.4:devel/py-appdirs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.11.1:www/py-beautifulsoup@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.11.1:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}frozendict>=2.3.4:devel/py-frozendict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>=1.1:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>=4.9.1:devel/py-lxml@${PY_FLAVOR} \
@@ -23,6 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.4:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}numpy>=1.16.5,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=1.3.0,1:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}peewee>=3.15.0:databases/py-peewee@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}platformdirs>=2.0.0:devel/py-platformdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2022.5,1:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.31:www/py-requests@${PY_FLAVOR}
diff --git a/finance/py-yfinance/distinfo b/finance/py-yfinance/distinfo
index 8692a0e04969..6e1bda50571e 100644
--- a/finance/py-yfinance/distinfo
+++ b/finance/py-yfinance/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1713528542
-SHA256 (yfinance-0.2.38.tar.gz) = 483eecae0743d829fc337f21d80da4612f5257d5c1f35570efc4a5e98e4401a7
-SIZE (yfinance-0.2.38.tar.gz) = 69498
+TIMESTAMP = 1716448716
+SHA256 (yfinance-0.2.40.tar.gz) = b053ac31229b5dc7f49a17a057f66aa7f688de2f5ddeb95c2455ec13cd89511a
+SIZE (yfinance-0.2.40.tar.gz) = 84161
diff --git a/finance/py-yfinance/files/patch-setup.py b/finance/py-yfinance/files/patch-setup.py
index 3e1a658ac247..d46665a24eca 100644
--- a/finance/py-yfinance/files/patch-setup.py
+++ b/finance/py-yfinance/files/patch-setup.py
@@ -1,11 +1,11 @@
---- setup.py.orig 2023-09-22 11:04:41 UTC
+--- setup.py.orig 2024-05-19 16:27:51 UTC
+++ setup.py
@@ -62,7 +62,7 @@ setup(
install_requires=['pandas>=1.3.0', 'numpy>=1.16.5',
'requests>=2.31', 'multitasking>=0.0.7',
- 'lxml>=4.9.1', 'appdirs>=1.4.4', 'pytz>=2022.5',
+ 'lxml>=4.9.1', 'platformdirs>=2.0.0', 'pytz>=2022.5',
- 'frozendict>=2.3.4', 'peewee>=3.16.2',
+ 'frozendict>=2.3.4', 'peewee>=3.15.0',
'beautifulsoup4>=4.11.1', 'html5lib>=1.1'],
- # Note: Pandas.read_html() needs html5lib & beautifulsoup4
- entry_points={
+ extras_require={
+ 'nospam': ['requests_cache>=1.0', 'requests_ratelimiter>=0.3.1'],