aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-25 20:23:20 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-25 20:23:20 +0000
commit9a3b512fbe4ca0bc90a8ec13f72f1f70a9e55758 (patch)
tree61b34cadb6f3d00c8a891616a8454b0a55e42def
parent5fbed83bbe5e1b68926b507037570bfd037ec4ff (diff)
downloadports-9a3b512fbe4ca0bc90a8ec13f72f1f70a9e55758.tar.gz
ports-9a3b512fbe4ca0bc90a8ec13f72f1f70a9e55758.zip
x11/radare-cutter: don't use webengine where it's not available
Builds fine without it.
-rw-r--r--x11/radare-cutter/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11/radare-cutter/Makefile b/x11/radare-cutter/Makefile
index f3b90a2dea43..56ee7d9c0bbf 100644
--- a/x11/radare-cutter/Makefile
+++ b/x11/radare-cutter/Makefile
@@ -22,13 +22,19 @@ GH_PROJECT= r2cutter
GH_TUPLE= radareorg:cutter-translations:8e1d24b:translations/translations
USE_QT= core declarative gui linguist location network printsupport svg \
- webchannel webengine widgets buildtools_build
+ webchannel widgets buildtools_build
USE_GL= gl
WRKSRC_SUBDIR= src
CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386
+USE_QT+= webengine
+.endif
+
post-patch:
@${REINPLACE_CMD} 's/python3/python-${PYTHON_VER}/' ${WRKSRC}/Cutter.pro