aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-06-15 16:31:34 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-06-16 18:03:01 +0000
commit9a521a21bc60d34292ce87e3099f52ec9232d022 (patch)
treee5a716914e2cbae93bfd8bb0434474b07b532c77
parenta579bac9a284dce12afaf09214cea09311297635 (diff)
downloadports-9a521a21bc60d34292ce87e3099f52ec9232d022.tar.gz
ports-9a521a21bc60d34292ce87e3099f52ec9232d022.zip
audio/festival: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because audio/festival's build infrastructure does not explicitly set its C++ standard, this leads to an error: regexp.cc:178:22: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] STATIC char *regnext(register char *p); ^~~~~~~~~ To work around the error, add USE_CXXSTD=gnu++11 to compile for C++11 with GNU extensions instead. While here, pet portlint a little. PR: 272014 Approved by: fernape MFH: 2023Q2
-rw-r--r--audio/festival/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 05001c346ef7..b9ce50db94b5 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -24,12 +24,14 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Multi-lingual speech synthesis system
WWW= https://www.cstr.ed.ac.uk/projects/festival/
+USES= gmake
+USE_CXXSTD= gnu++11
+
OPTIONS_DEFINE= NAS
OPTIONS_DEFAULT=NAS
CXXFLAGS+= -DFTLIBDIR=${LOCALBASE}/share/festival/lib -fno-delete-null-pointer-checks
CONFIGURE_WRKSRC=${WRKDIR}/festival
-USES= gmake
SPEECHTOOLS= ${WRKSRC}/speech_tools
FESTIVAL= ${WRKSRC}/festival
MAKE_ARGS+= CC="${CCACHE_BIN} ${CC}" GCC="${CCACHE_BIN} ${CC}" \