aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPat Maddox <pat@patmaddox.com>2023-10-21 18:12:23 +0000
committerKurt Jaeger <pi@FreeBSD.org>2023-10-21 18:12:23 +0000
commit9a92113d5600ea70f07b891a5aa2946a10f0c0f5 (patch)
tree8d85aec688791433b13c97966ee108647e525a75
parent58a7baab60ed793e6c95a819f95b5a989ebf574d (diff)
downloadports-9a92113d5600ea70f07b891a5aa2946a10f0c0f5.tar.gz
ports-9a92113d5600ea70f07b891a5aa2946a10f0c0f5.zip
devel/py-minimal-snowplow-tracker: new port
Add analytics to your Python apps and Python games with the Snowplow event tracker for Python. With this tracker you can collect event data from your Python-based applications, games or Python web servers/frameworks. This is a fork of the original Snowplow Python tracker v0.8.0, with a number of changes: - All emitters except for the basic one removed - Tests converted to docker - All tracking event methods except for structured/unstructured removed - Python 3.7 supported PR: 274580 Author: Pat Maddox <pat@patmaddox.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-minimal-snowplow-tracker/Makefile19
-rw-r--r--devel/py-minimal-snowplow-tracker/distinfo3
-rw-r--r--devel/py-minimal-snowplow-tracker/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 126629232271..a006258149b6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4999,6 +4999,7 @@
SUBDIR += py-mime
SUBDIR += py-miniKanren
SUBDIR += py-minidump
+ SUBDIR += py-minimal-snowplow-tracker
SUBDIR += py-minimongo
SUBDIR += py-minio
SUBDIR += py-mock
diff --git a/devel/py-minimal-snowplow-tracker/Makefile b/devel/py-minimal-snowplow-tracker/Makefile
new file mode 100644
index 000000000000..958f40d00b77
--- /dev/null
+++ b/devel/py-minimal-snowplow-tracker/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= minimal-snowplow-tracker
+PORTVERSION= 0.0.2
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pat@patmaddox.com
+COMMENT= Snowplow event tracker. Add analytics to Python apps and webapps
+WWW= https://pypi.org/project/minimal-snowplow-tracker/
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2.1,<3.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0,<2.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-minimal-snowplow-tracker/distinfo b/devel/py-minimal-snowplow-tracker/distinfo
new file mode 100644
index 000000000000..7c793c9f2e62
--- /dev/null
+++ b/devel/py-minimal-snowplow-tracker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691524073
+SHA256 (minimal-snowplow-tracker-0.0.2.tar.gz) = acabf7572db0e7f5cbf6983d495eef54081f71be392330eb3aadb9ccb39daaa4
+SIZE (minimal-snowplow-tracker-0.0.2.tar.gz) = 12542
diff --git a/devel/py-minimal-snowplow-tracker/pkg-descr b/devel/py-minimal-snowplow-tracker/pkg-descr
new file mode 100644
index 000000000000..8d91fd746415
--- /dev/null
+++ b/devel/py-minimal-snowplow-tracker/pkg-descr
@@ -0,0 +1,12 @@
+Add analytics to your Python apps and Python games with the Snowplow event
+tracker for Python.
+
+With this tracker you can collect event data from your Python-based
+applications, games or Python web servers/frameworks.
+
+This is a fork of the original Snowplow Python tracker v0.8.0, with a number of
+changes:
+- All emitters except for the basic one removed
+- Tests converted to docker
+- All tracking event methods except for structured/unstructured removed
+- Python 3.7 supported