aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2023-07-01 10:04:53 +0000
committerNicola Vitale <nivit@FreeBSD.org>2023-07-01 10:04:53 +0000
commit9ad0e87dc603380bc1203ee6ddfdf630df7b05eb (patch)
tree5e51e00caf3c5a328aa03748acac434613491911
parentf645a2a1a9683bc3b218bdf957d87c0f9699c48d (diff)
downloadports-9ad0e87dc603380bc1203ee6ddfdf630df7b05eb.tar.gz
ports-9ad0e87dc603380bc1203ee6ddfdf630df7b05eb.zip
multimedia/py-tartube: Add new port
Tartube is a GUI front-end for youtube-dl, yt-dlp and other compatible video downloaders. It is written in Python 3 / Gtk 3 and runs on MS Windows, Linux, BSD and MacOS. https://github.com/axcore/tartube
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/py-tartube/Makefile40
-rw-r--r--multimedia/py-tartube/distinfo3
-rw-r--r--multimedia/py-tartube/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index d1ce4df0e359..ad3c778868c1 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -318,6 +318,7 @@
SUBDIR += py-pysubs2
SUBDIR += py-soco
SUBDIR += py-subliminal
+ SUBDIR += py-tartube
SUBDIR += py-tvnamer
SUBDIR += qmmp-plugin-pack-qt5
SUBDIR += qmmp-plugin-pack-qt6
diff --git a/multimedia/py-tartube/Makefile b/multimedia/py-tartube/Makefile
new file mode 100644
index 000000000000..d6d02b53d544
--- /dev/null
+++ b/multimedia/py-tartube/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= tartube
+DISTVERSION= 2.4.386
+CATEGORIES= multimedia python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= GUI front-end for youtube-dl/yt-dlp, written in Python
+WWW= https://github.com/axcore/tartube
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=6.0.8:textproc/py-feedparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject3>=3.42.2:devel/py-gobject3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.7.1:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}moviepy>=1.0.3:multimedia/py-moviepy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}playsound>=1.3.0:audio/py-playsound@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.31.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}streamlink>=5.5.1:multimedia/streamlink@${PY_FLAVOR} \
+ aria2c:www/aria2 \
+ AtomicParsley:multimedia/atomicparsley \
+ ffmpeg:multimedia/ffmpeg \
+ yt-dlp:www/yt-dlp
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+MAKE_ENV= TARTUBE_PKG_STRICT=1
+
+NO_ARCH= yes
+
+post-patch:
+ ${SED} -i.bak -e "s|\( = '\)/usr/share/tartube|\1${DATADIR}|1" ${WRKSRC}/setup.py
+ ${SED} -i.bak -e "s|'/', 'usr', 'share', __main__.__packagename__|'${DATADIR}'|g" \
+ -e "s|\(self.ytdl_path =\) None|\1 '${LOCALBASE}/bin/yt-dlp'|1" \
+ ${WRKSRC}/tartube/mainapp.py \
+ ${WRKSRC}/tartube/mainwin.py
+
+.include <bsd.port.mk>
diff --git a/multimedia/py-tartube/distinfo b/multimedia/py-tartube/distinfo
new file mode 100644
index 000000000000..ed5dd3c98d10
--- /dev/null
+++ b/multimedia/py-tartube/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688141639
+SHA256 (tartube-2.4.386.tar.gz) = aafc61c6341d82202163135ba83ce0de471375dc88572e62d15416620f973779
+SIZE (tartube-2.4.386.tar.gz) = 9451523
diff --git a/multimedia/py-tartube/pkg-descr b/multimedia/py-tartube/pkg-descr
new file mode 100644
index 000000000000..ab32fa67a259
--- /dev/null
+++ b/multimedia/py-tartube/pkg-descr
@@ -0,0 +1,5 @@
+Tartube is a GUI front-end for youtube-dl, yt-dlp and other compatible video
+downloaders.
+
+It is written in Python 3 / Gtk 3 and runs on MS Windows, Linux, BSD and
+MacOS.