aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-28 12:58:28 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-31 10:42:05 +0000
commit9ae57bb754413fc9394ccad44c97926175df61a0 (patch)
tree232b76b2b8d1e21ff8ccfa681af0a2404b4b3fd0
parentfdf60984b2ec8d7da066d407713ae31eb0f9931c (diff)
downloadports-9ae57bb754413fc9394ccad44c97926175df61a0.tar.gz
ports-9ae57bb754413fc9394ccad44c97926175df61a0.zip
graphics/lux: update to 1.1.6
Patch out an unused SIMD function that didn't build on i386 as per upstream instructions. Changelog: https://groups.google.com/g/hugin-ptx/c/RFnsB3JyKpU/m/zrbdlQlDEQAJ
-rw-r--r--graphics/lux/Makefile5
-rw-r--r--graphics/lux/distinfo6
-rw-r--r--graphics/lux/files/patch-vspline_hwy__simd__type.h10
3 files changed, 15 insertions, 6 deletions
diff --git a/graphics/lux/Makefile b/graphics/lux/Makefile
index 1432f31cc198..e856e76e6cd8 100644
--- a/graphics/lux/Makefile
+++ b/graphics/lux/Makefile
@@ -1,5 +1,5 @@
PORTNAME= lux
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.6
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/kfj/pv/get/
PKGNAMESUFFIX= -pv # distinguish from www/lux
@@ -29,8 +29,7 @@ CXXFLAGS+= -Wno-deprecated-declarations
CONFLICTS= lux
WRKSRC= ${WRKDIR}/kfj-pv-${COMMIT}
-COMMIT= 4a1b894733a2
-
+COMMIT= f49809a01243
OPTIONS_DEFINE_amd64= SSSE3 SSE42 AVX AVX2 AVX512
OPTIONS_DEFINE_i386= SSE2 SSSE3 SSE42 AVX AVX2 AVX512
OPTIONS_DEFAULT_amd64= SSSE3 SSE42 AVX AVX2 AVX512
diff --git a/graphics/lux/distinfo b/graphics/lux/distinfo
index 0026a3e9b5e8..8605a78a504a 100644
--- a/graphics/lux/distinfo
+++ b/graphics/lux/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675961713
-SHA256 (4a1b894733a2.tar.bz2) = 008bdbb6d38740aa984abbdf996f96521ec8dd0f7f0c0960150f5b6166aa0bbd
-SIZE (4a1b894733a2.tar.bz2) = 1158307
+TIMESTAMP = 1680004680
+SHA256 (f49809a01243.tar.bz2) = 96c9b961d7ed2c9947463a72558eb572df340990a87eeeba8e03e96ff3b191f5
+SIZE (f49809a01243.tar.bz2) = 1168741
diff --git a/graphics/lux/files/patch-vspline_hwy__simd__type.h b/graphics/lux/files/patch-vspline_hwy__simd__type.h
new file mode 100644
index 000000000000..a993421bfdc2
--- /dev/null
+++ b/graphics/lux/files/patch-vspline_hwy__simd__type.h
@@ -0,0 +1,10 @@
+--- vspline/hwy_simd_type.h.orig 2023-03-30 09:58:06 UTC
++++ vspline/hwy_simd_type.h
+@@ -694,7 +694,6 @@ PROMOTE(unsigned short,int)
+ PROMOTE(unsigned char,int)
+ PROMOTE(unsigned char,short)
+
+-PROMOTE(short,unsigned int)
+ PROMOTE(signed char,unsigned int)
+ PROMOTE(unsigned short,unsigned int)
+ PROMOTE(unsigned char,unsigned int)