aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2022-02-10 04:25:10 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2022-02-10 04:25:10 +0000
commit9aee742a9889550973266087d9c9d8a135e3dfea (patch)
tree7b0529516b939c6d2b73ce79f0e00d53b1f23b0c
parentcea2172378ff96bc9e8fea9fa9c9905af6a1d35e (diff)
downloadports-9aee742a9889550973266087d9c9d8a135e3dfea.tar.gz
ports-9aee742a9889550973266087d9c9d8a135e3dfea.zip
www/py-fastapi-users: Update to 9.2.4
-rw-r--r--www/py-fastapi-users/Makefile2
-rw-r--r--www/py-fastapi-users/distinfo6
-rw-r--r--www/py-fastapi-users/files/patch-setup.py52
3 files changed, 4 insertions, 56 deletions
diff --git a/www/py-fastapi-users/Makefile b/www/py-fastapi-users/Makefile
index afea11aa4333..51a5996c9150 100644
--- a/www/py-fastapi-users/Makefile
+++ b/www/py-fastapi-users/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fastapi-users
-PORTVERSION= 9.2.2
+PORTVERSION= 9.2.4
CATEGORIES= www devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-fastapi-users/distinfo b/www/py-fastapi-users/distinfo
index 7343f4599267..a24d88f2a740 100644
--- a/www/py-fastapi-users/distinfo
+++ b/www/py-fastapi-users/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643064924
-SHA256 (fastapi-users-9.2.2.tar.gz) = 59febb9302dd0590b6992343896437bd1941ec4c6726bf5abf9093d681a98f23
-SIZE (fastapi-users-9.2.2.tar.gz) = 103649
+TIMESTAMP = 1644412816
+SHA256 (fastapi-users-9.2.4.tar.gz) = 3a3773d582d161a1d790f4eb3d1da2229e853308f6be2bf3687396d077369b33
+SIZE (fastapi-users-9.2.4.tar.gz) = 104360
diff --git a/www/py-fastapi-users/files/patch-setup.py b/www/py-fastapi-users/files/patch-setup.py
deleted file mode 100644
index c56e9fe3c2d1..000000000000
--- a/www/py-fastapi-users/files/patch-setup.py
+++ /dev/null
@@ -1,52 +0,0 @@
---- setup.py.orig 2022-01-24 23:01:58 UTC
-+++ setup.py
-@@ -0,0 +1,49 @@
-+#!/usr/bin/env python
-+# setup.py generated by flit for tools that don't yet use PEP 517
-+
-+from distutils.core import setup
-+
-+packages = [
-+ "fastapi_users",
-+ "fastapi_users.authentication",
-+ "fastapi_users.authentication.strategy",
-+ "fastapi_users.authentication.strategy.db",
-+ "fastapi_users.authentication.transport",
-+ "fastapi_users.db",
-+ "fastapi_users.router",
-+]
-+
-+package_data = {"": ["*"]}
-+
-+install_requires = [
-+ "fastapi >=0.65.2,<0.72.0",
-+ "passlib[bcrypt] ==1.7.4",
-+ "email-validator >=1.1.0,<1.2",
-+ "pyjwt ==2.3.0",
-+ "python-multipart ==0.0.5",
-+ "makefun >=1.11.2,<1.14",
-+]
-+
-+extras_require = {
-+ "mongodb": ["fastapi-users-db-mongodb >=1.1.0"],
-+ "oauth": ["httpx-oauth >=0.4,<0.5"],
-+ "ormar": ["fastapi-users-db-ormar >=1.0.0"],
-+ "redis": ["aioredis >=2.0.1,<2.1.0", "hiredis >=2.0.0,<2.1.0"],
-+ "sqlalchemy": ["fastapi-users-db-sqlalchemy >=1.1.0,<2.0.0"],
-+ "sqlalchemy2": ["fastapi-users-db-sqlalchemy >=2.0.0"],
-+ "tortoise-orm": ["fastapi-users-db-tortoise >=1.1.0"],
-+}
-+
-+setup(
-+ name="fastapi-users",
-+ version="9.2.2",
-+ description="Ready-to-use and customizable users management for FastAPI.",
-+ author="François Voron",
-+ author_email="fvoron@gmail.com",
-+ url="https://github.com/fastapi-users/fastapi-users",
-+ packages=packages,
-+ package_data=package_data,
-+ install_requires=install_requires,
-+ extras_require=extras_require,
-+ python_requires=">=3.7",
-+)