aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:44:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:41 +0000
commit9b1657fb942c92d967ee3a298e93caafb7ec2a8b (patch)
treee0ad85ad3d8de1fa58894dbf6111bb402255ff67
parent309a8a20a1a39dcaba12f139ed53ac087a53e49c (diff)
downloadports-9b1657fb942c92d967ee3a298e93caafb7ec2a8b.tar.gz
ports-9b1657fb942c92d967ee3a298e93caafb7ec2a8b.zip
devel/py-inflect: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-inflect/Makefile10
-rw-r--r--devel/py-inflect/files/setup.py3
2 files changed, 5 insertions, 8 deletions
diff --git a/devel/py-inflect/Makefile b/devel/py-inflect/Makefile
index b73363094f07..fc59ec4ae6d9 100644
--- a/devel/py-inflect/Makefile
+++ b/devel/py-inflect/Makefile
@@ -1,5 +1,6 @@
PORTNAME= inflect
PORTVERSION= 6.0.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,15 +12,14 @@ WWW= https://github.com/jaraco/inflect
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydantic>=1.9.1:devel/py-pydantic@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-inflect/files/setup.py b/devel/py-inflect/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-inflect/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()