aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-04-25 08:51:18 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-04-25 08:51:18 +0000
commit9b1daa854f85e486ed1177746408892e09e3a138 (patch)
treec8c2f725d3838c37f250c6936fd83738594e1256
parent2ebb5fb606f0486014dfbd6b282886bef9197dae (diff)
downloadports-9b1daa854f85e486ed1177746408892e09e3a138.tar.gz
ports-9b1daa854f85e486ed1177746408892e09e3a138.zip
sysutils/conky: Force linking against correct LUA
When multiple LUA versions are present conky could link against version 5.3 but register dependency against version 5.2. Try to force conky build system to actually link against the desired version of the library. Reported by: Joachim Moskalewski <moskalewski@jmos.net>
-rw-r--r--sysutils/conky/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 4eabc66d7ca7..045a8d395c8e 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -144,6 +144,15 @@ post-patch:
${WRKSRC}/cmake/ConkyPlatformChecks.cmake
@${REINPLACE_CMD} -e 's,LOCALBASE,${LOCALBASE},' \
${WRKSRC}/doc/docgen.sh
+.if ${LUA_DEFAULT} == 5.2
+ # Force using lua 5.2
+ @${REINPLACE_CMD} -e 's/lua.*5\.*3//' \
+ ${WRKSRC}/cmake/ConkyPlatformChecks.cmake
+.elif ${LUA_DEFAULT} == 5.3
+ # Force using lua 5.3
+ @${REINPLACE_CMD} -e 's/lua.*5\.*2//' \
+ ${WRKSRC}/cmake/ConkyPlatformChecks.cmake
+.endif
post-build:
(cd ${WRKSRC}/doc && ${SH} docgen.sh)