aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2021-11-16 12:36:59 +0000
committerAlex Dupre <ale@FreeBSD.org>2021-11-16 12:37:22 +0000
commit9b57fdd36f3ea6b7474e074f496ace9abc42ce37 (patch)
tree4ee0a305b870b051d5b5935e016f53eaacd849a1
parent4342af9ae5e56b4c1ace128f99c60bf29a44cc51 (diff)
downloadports-9b57fdd36f3ea6b7474e074f496ace9abc42ce37.tar.gz
ports-9b57fdd36f3ea6b7474e074f496ace9abc42ce37.zip
lang/solidity: update to 0.8.10 release.
-rw-r--r--lang/solidity/Makefile6
-rw-r--r--lang/solidity/distinfo6
-rw-r--r--lang/solidity/files/fmtlib.cmake1
3 files changed, 7 insertions, 6 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index f814ea59ef2f..b502fd8859fd 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -1,8 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
PORTNAME= solidity
-PORTVERSION= 0.8.9
-PORTREVISION= 1
+PORTVERSION= 0.8.10
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,6 +15,7 @@ NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS_REASON= solidity currently does not support big endian systems
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs \
+ libfmt>=0:devel/libfmt \
range-v3>=0:devel/range-v3
LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
@@ -41,7 +41,7 @@ PLIST_FILES= bin/solc \
bin/yul-phaser
pre-patch:
- @${CP} ${FILESDIR}/jsoncpp.cmake ${WRKSRC}/cmake/
+ @${CP} ${FILESDIR}/fmtlib.cmake ${FILESDIR}/jsoncpp.cmake ${WRKSRC}/cmake/
@${REINPLACE_CMD} '/EthCcache/d' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/lang/solidity/distinfo b/lang/solidity/distinfo
index fc6b9a686648..3b8cdcb53e70 100644
--- a/lang/solidity/distinfo
+++ b/lang/solidity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632988531
-SHA256 (solidity_0.8.9.tar.gz) = 36643d0282998136b610f740808acb4dc6728144bb9ee70e5fd4124cda85ddab
-SIZE (solidity_0.8.9.tar.gz) = 2871614
+TIMESTAMP = 1637061650
+SHA256 (solidity_0.8.10.tar.gz) = 3f157aa2bc8bcbd8975fe5e41c476b3d777432dfe7c64e9d59247ee225a89ee3
+SIZE (solidity_0.8.10.tar.gz) = 3076003
diff --git a/lang/solidity/files/fmtlib.cmake b/lang/solidity/files/fmtlib.cmake
new file mode 100644
index 000000000000..c6d3a73d00fb
--- /dev/null
+++ b/lang/solidity/files/fmtlib.cmake
@@ -0,0 +1 @@
+find_package(fmt REQUIRED)