aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorports@blievers.net <ports@blievers.net>2023-09-25 20:45:20 +0000
committerJoel Bodenmann <jbo@FreeBSD.org>2023-10-03 11:06:54 +0000
commit9c67d516b56bd08cd3d95f0c2095cbf7803407f7 (patch)
treeb33391e85c011066b2f4f5c81aee05536a663cf8
parentebbe5273eba1ef829e4ff1a6bd7cfdc0ff9905ab (diff)
downloadports-9c67d516b56bd08cd3d95f0c2095cbf7803407f7.tar.gz
ports-9c67d516b56bd08cd3d95f0c2095cbf7803407f7.zip
multimedia/motion: Update to 4.5.1
-rw-r--r--multimedia/motion/Makefile67
-rw-r--r--multimedia/motion/distinfo8
-rw-r--r--multimedia/motion/pkg-plist31
3 files changed, 48 insertions, 58 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index e90cd7e207f6..f85deae22be8 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -1,8 +1,7 @@
# PORTNAME block
PORTNAME= motion
-PORTVERSION= 4.3.2
-PORTREVISION= 8
DISTVERSIONPREFIX= release-
+DISTVERSION= 4.5.1
CATEGORIES= multimedia
# Maintainer block
@@ -12,14 +11,14 @@ WWW= https://motion-project.github.io/
# License block
LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/doc/COPYING
+LICENSE_FILE= ${WRKSRC}/LICENSE
# Dependencies
LIB_DEPENDS= libwebp.so:graphics/webp \
libmicrohttpd.so:www/libmicrohttpd
# USES block
-USES= autoreconf cpe gmake jpeg localbase pkgconfig gettext
+USES= autoreconf cpe gmake jpeg localbase pkgconfig
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
@@ -28,29 +27,16 @@ USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/ffmpeg4/include
-LDFLAGS+= -L${LOCALBASE}/ffmpeg4/lib
-CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
-MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
-
# Standard bsd.port.mk variables
SUB_FILES= pkg-message
-# Packaging list block
-PLIST_FILES= bin/motion \
- man/man1/motion.1.gz \
- "@sample ${ETCDIR}/motion.conf.sample" \
- "@dir ${ETCDIR}/conf.d"
-PORTDOCS= *
-
-PORTEXAMPLES= camera1-dist.conf camera2-dist.conf \
- camera3-dist.conf camera4-dist.conf
-
# Options definitions
-OPTIONS_DEFINE= DOCS EXAMPLES FFMPEG MYSQL PGSQL SQLITE3
+OPTIONS_DEFINE= DOCS EXAMPLES FFMPEG MYSQL PGSQL SQLITE3 NLS
+
OPTIONS_DEFAULT= WEBCAMD FFMPEG
OPTIONS_RADIO= VIDEO
OPTIONS_RADIO_VIDEO= BKTR PWCBSD WEBCAMD
+OPTIONS_SUB= yes
BKTR_DESC= BKTR based TV capture cards
@@ -61,18 +47,17 @@ WEBCAMD_DESC= Webcams using webcamd
BKTR_CONFIGURE_WITH= bktr
-FFMPEG_LIB_DEPENDS= libavformat.so.58:multimedia/ffmpeg4
-FFMPEG_CONFIGURE_ON= --with-ffmpeg=${LOCALBASE}/ffmpeg4
-FFMPEG_CONFIGURE_OFF= --without-ffmpeg
+FFMPEG_LIB_DEPENDS= libavformat.so.60:multimedia/ffmpeg
+FFMPEG_CONFIGURE_WITH= ffmpeg
MYSQL_USES= mysql
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}/include/mysql
-MYSQL_CONFIGURE_OFF= --without-mysql
+MYSQL_CONFIGURE_WITH= mysql
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-pgsql-lib=${LOCALBASE}/lib \
- --with-pgsql-include=${LOCALBASE}/include
-PGSQL_CONFIGURE_OFF= --without-pgsql
+PGSQL_CONFIGURE_WITH= pgsql
PWCBSD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
PWCBSD_RUN_DEPENDS= pwcbsd>0:multimedia/pwcbsd
@@ -85,28 +70,4 @@ WEBCAMD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
# note: all configure --with-pwcbsd does is not shut off v4l support
WEBCAMD_CONFIGURE_WITH= pwcbsd
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure.ac
-# Fix pidfile path
- @${REINPLACE_CMD} -e \
- 's|/run/motion|/run|' ${WRKSRC}/data/motion-dist.conf.in
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/motion ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/motion.1 ${STAGEDIR}${MANPREFIX}/man/man1
- @${MKDIR} ${STAGEDIR}${ETCDIR}/conf.d
- ${INSTALL_DATA} ${WRKSRC}/data/motion-dist.conf \
- ${STAGEDIR}${ETCDIR}/motion.conf.sample
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-
-do-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/data/|} ${STAGEDIR}${EXAMPLESDIR}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/motion/distinfo b/multimedia/motion/distinfo
index c05734dbfad2..e67f71ef55e2 100644
--- a/multimedia/motion/distinfo
+++ b/multimedia/motion/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1695017850
-SHA256 (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = dafa4264b2d8e4778f8be5871f09b6c0ec710d5a836182c583469c18db944d70
-SIZE (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = 849378
-SHA256 (af632f831127499ee541d9c719a930321718f294.patch) = 85dc0562c7dc358084c8c9556ebb8ef1592527d79f576f035f356bbdadf40c6c
-SIZE (af632f831127499ee541d9c719a930321718f294.patch) = 890
+TIMESTAMP = 1694746910
+SHA256 (Motion-Project-motion-release-4.5.1_GH0.tar.gz) = 0c824276bb23565b7cf10409ebdcb46b85fb1f6abca957252e52290bb1fe473e
+SIZE (Motion-Project-motion-release-4.5.1_GH0.tar.gz) = 856665
diff --git a/multimedia/motion/pkg-plist b/multimedia/motion/pkg-plist
new file mode 100644
index 000000000000..e0eb8a7b5463
--- /dev/null
+++ b/multimedia/motion/pkg-plist
@@ -0,0 +1,31 @@
+bin/motion
+man/man1/motion.1.gz
+%%ETCDIR%%/camera1-dist.conf
+%%ETCDIR%%/camera2-dist.conf
+%%ETCDIR%%/camera3-dist.conf
+%%ETCDIR%%/camera4-dist.conf
+%%ETCDIR%%/motion-dist.conf
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/mask1.png
+%%PORTDOCS%%%%DOCSDIR%%/motion_build.html
+%%PORTDOCS%%%%DOCSDIR%%/motion_config.html
+%%PORTDOCS%%%%DOCSDIR%%/motion_guide.html
+%%PORTDOCS%%%%DOCSDIR%%/motion_stylesheet.css
+%%PORTDOCS%%%%DOCSDIR%%/normal.jpg
+%%PORTDOCS%%%%DOCSDIR%%/outputmotion1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/outputnormal1.jpg
+%%NLS%%share/locale/da/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/de/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/es/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/it/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/li/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/no/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/motion.mo
+%%NLS%%share/locale/zh/LC_MESSAGES/motion.mo