aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2022-11-23 11:51:44 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2024-01-13 08:17:23 +0000
commit9c8633f6b2061d35c78e745fbafb7666357eaa8e (patch)
tree621400fcd5ea16bd0472da479731191b6350efe4
parentf942dcfd4f8e0fa3edab21719c55ee34c7f99fca (diff)
downloadports-9c8633f6b2061d35c78e745fbafb7666357eaa8e.tar.gz
ports-9c8633f6b2061d35c78e745fbafb7666357eaa8e.zip
lang/gcc13-devel: Fix Address sanitizer
Software compiled with -fsanitize=address fails to run with the error message "ASan runtime does not come first in initial library list; you should either link runtime to your application or manually preload it with LD_PRELOAD". This commit fixes the issue by ignoring the [vdso] loaded shared library instead of linux-vdso.so. To successfully run the software compiled with -fsanitize=address it is still necessary to disable ASLR. PR: 267751 Reported by: yuri Co-authored-by: Andreas Tobler <andreast@gcc.gnu.org>
-rw-r--r--lang/gcc13-devel/Makefile2
-rw-r--r--lang/gcc13-devel/files/patch-libsanitizer_asan_asan__linux.cpp23
-rw-r--r--lang/gcc13-devel/files/patch-libsanitizer_asan_asan__thread.cpp13
3 files changed, 37 insertions, 1 deletions
diff --git a/lang/gcc13-devel/Makefile b/lang/gcc13-devel/Makefile
index 9a5859c15d39..2d3dfa12be7f 100644
--- a/lang/gcc13-devel/Makefile
+++ b/lang/gcc13-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gcc
PORTVERSION= 13.2.1.s20240106
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__linux.cpp b/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__linux.cpp
new file mode 100644
index 000000000000..f6c16d8730ee
--- /dev/null
+++ b/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__linux.cpp
@@ -0,0 +1,23 @@
+Since the vDSO shared librares on Linux and FreeBSD are called
+differently, the initialization order check fails on FreeBSD.
+This patch fixes it by ignoring [vdso] instead of linux-vdso.so.
+
+GCC gets the original file from the LLVM Project, so this patch should
+probably be upstreamed directly to the LLVM Project rather than to GCC.
+
+
+--- libsanitizer/asan/asan_linux.cpp.orig 2022-11-23 11:22:41 UTC
++++ libsanitizer/asan/asan_linux.cpp
+@@ -148,6 +148,12 @@ static int FindFirstDSOCallback(struct dl_phdr_info *i
+ return 0;
+ # endif
+
++# if SANITIZER_FREEBSD
++ // Ignore vDSO
++ if (internal_strncmp(info->dlpi_name, "[vdso]", sizeof("[vdso]") - 1) == 0)
++ return 0;
++# endif
++
+ *name = info->dlpi_name;
+ return 1;
+ }
diff --git a/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__thread.cpp b/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__thread.cpp
new file mode 100644
index 000000000000..61c0ccf1cd89
--- /dev/null
+++ b/lang/gcc13-devel/files/patch-libsanitizer_asan_asan__thread.cpp
@@ -0,0 +1,13 @@
+--- libsanitizer/asan/asan_thread.cpp.orig 2024-01-12 13:45:52 UTC
++++ libsanitizer/asan/asan_thread.cpp
+@@ -323,7 +323,9 @@ void AsanThread::ClearShadowForThreadStackAndTLS() {
+ if (tls_begin_ != tls_end_) {
+ uptr tls_begin_aligned = RoundDownTo(tls_begin_, ASAN_SHADOW_GRANULARITY);
+ uptr tls_end_aligned = RoundUpTo(tls_end_, ASAN_SHADOW_GRANULARITY);
+- FastPoisonShadow(tls_begin_aligned, tls_end_aligned - tls_begin_aligned, 0);
++ FastPoisonShadowPartialRightRedzone(tls_begin_aligned,
++ tls_end_ - tls_begin_aligned,
++ tls_end_aligned - tls_end_, 0);
+ }
+ }
+