aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:43:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:38 +0000
commit9cea5ae667829a660500e9796d304e2d776f9568 (patch)
tree16e0a734ea7a6de2f16f191e048c0c824290098b
parent92d7f0316ce1fc988bf07f53936c1e2a117a48e4 (diff)
downloadports-9cea5ae667829a660500e9796d304e2d776f9568.tar.gz
ports-9cea5ae667829a660500e9796d304e2d776f9568.zip
devel/py-flit-scm: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-flit-scm/Makefile10
-rw-r--r--devel/py-flit-scm/files/setup.py29
2 files changed, 6 insertions, 33 deletions
diff --git a/devel/py-flit-scm/Makefile b/devel/py-flit-scm/Makefile
index f6c0cf4ba341..73ef8f48e097 100644
--- a/devel/py-flit-scm/Makefile
+++ b/devel/py-flit-scm/Makefile
@@ -1,5 +1,6 @@
PORTNAME= flit-scm
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,21 +13,22 @@ WWW= https://gitlab.com/WillDaSilva/flit_scm
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.5<4:devel/py-flit-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.4:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.5<4:devel/py-flit-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.4:devel/py-setuptools_scm@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 31100
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
+
diff --git a/devel/py-flit-scm/files/setup.py b/devel/py-flit-scm/files/setup.py
deleted file mode 100644
index 482fbc9e8ec9..000000000000
--- a/devel/py-flit-scm/files/setup.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['flit_scm']
-
-package_data = \
-{'': ['*']}
-
-install_requires = \
-['flit-core~=3.5', 'setuptools_scm>=6.4']
-
-extras_require = \
-{":python_version < '3.11'": ['tomli']}
-
-setup(name='flit_scm',
- version='%%PORTVERSION%%',
- description='A PEP 518 build backend that uses setuptools_scm to generate a version file from your version control system, then flit to build the package.',
- author=None,
- author_email='Will Da Silva <will@willdasilva.xyz>',
- url=None,
- packages=packages,
- package_data=package_data,
- install_requires=install_requires,
- extras_require=extras_require,
- python_requires='>=3.6',
- )