aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-23 02:36:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-23 02:37:36 +0000
commit9d053ab98557a1b101c5438bf43f99b356a53484 (patch)
tree73b17e1da80b95f5fd694222c9cfe4505642e6c7
parent4aae031714438312737a2d9c4282bab5a055b798 (diff)
downloadports-9d053ab98557a1b101c5438bf43f99b356a53484.tar.gz
ports-9d053ab98557a1b101c5438bf43f99b356a53484.zip
audio/ssr-lv2: New port: Sympathetic string resonator LV2 plugin
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ssr-lv2/Makefile36
-rw-r--r--audio/ssr-lv2/distinfo5
-rw-r--r--audio/ssr-lv2/files/mntent.h62
-rw-r--r--audio/ssr-lv2/files/patch-thirdparty_cpuid_platform_src_platform_config.hpp11
-rw-r--r--audio/ssr-lv2/files/patch-thirdparty_cpuid_src_cpuid_cpuinfo.cpp11
-rw-r--r--audio/ssr-lv2/pkg-descr7
7 files changed, 133 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 777f84b45ea9..d14a9ef0c85b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -770,6 +770,7 @@
SUBDIR += squash
SUBDIR += squeezelite
SUBDIR += sratom
+ SUBDIR += ssr-lv2
SUBDIR += stegosaurus-lv2
SUBDIR += stk
SUBDIR += stmp
diff --git a/audio/ssr-lv2/Makefile b/audio/ssr-lv2/Makefile
new file mode 100644
index 000000000000..a0dd5da73c44
--- /dev/null
+++ b/audio/ssr-lv2/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= ssr
+DISTVERSION= g20210922
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Sympathetic string resonator LV2 plugin
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ bash:shells/bash
+LIB_DEPENDS= libjack.so:audio/jack
+
+USES= compiler:c++11-lang gmake gnome pkgconfig shebangfix xorg
+USE_GNOME= cairo
+USE_XORG= x11
+
+USE_GITHUB= yes
+GH_ACCOUNT= jpcima
+GH_TAGNAME= e1999da
+GH_TUPLE= DISTRHO:DPF:220d364:dpf/dpf
+
+SHEBANG_FILES= dpf/utils/generate-ttl.sh
+
+CFLAGS+= -I${FILESDIR}
+
+PLIST_FILES= bin/ssr \
+ lib/lv2/ssr.lv2/manifest.ttl \
+ lib/lv2/ssr.lv2/ssr_dsp.so \
+ lib/lv2/ssr.lv2/ssr_dsp.ttl \
+ lib/lv2/ssr.lv2/ssr_ui.so \
+ lib/lv2/ssr.lv2/ssr_ui.ttl
+
+.include <bsd.port.mk>
diff --git a/audio/ssr-lv2/distinfo b/audio/ssr-lv2/distinfo
new file mode 100644
index 000000000000..737f3e742325
--- /dev/null
+++ b/audio/ssr-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1632363258
+SHA256 (jpcima-ssr-g20210922-e1999da_GH0.tar.gz) = 63453bc86786eedb1319e1437664759ccce9edee0a3d7c1879662eb6f7a61945
+SIZE (jpcima-ssr-g20210922-e1999da_GH0.tar.gz) = 294335
+SHA256 (DISTRHO-DPF-220d364_GH0.tar.gz) = b9f30c63c723241f9ea0211b12db7dcd97b76dc6df877f3676f3683491dde03f
+SIZE (DISTRHO-DPF-220d364_GH0.tar.gz) = 2119950
diff --git a/audio/ssr-lv2/files/mntent.h b/audio/ssr-lv2/files/mntent.h
new file mode 100644
index 000000000000..e61cddd89c82
--- /dev/null
+++ b/audio/ssr-lv2/files/mntent.h
@@ -0,0 +1,62 @@
+/*
+ * mntent
+ * mntent.h - compatability header for FreeBSD
+ *
+ * Copyright (c) 2001 David Rufino <daverufino@btinternet.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#if defined(HAVE_MNTENT_H)
+#include <mntent.h>
+#else
+#ifndef _MNTENT_H
+#define _MNTENT_H
+#include <stdio.h>
+
+#define MOUNTED "dummy"
+
+#define MNTTYPE_NFS "nfs"
+
+struct mntent {
+ char *mnt_fsname;
+ char *mnt_dir;
+ char *mnt_type;
+ char *mnt_opts;
+ int mnt_freq;
+ int mnt_passno;
+};
+
+#define setmntent(x,y) ((FILE *)0x1)
+#ifdef __cplusplus
+extern "C" {
+#endif
+struct mntent *getmntent __P ((FILE *fp));
+char *hasmntopt __P ((const struct mntent *mnt, const char *option));
+#ifdef __cplusplus
+}; // extern "C"
+#endif
+#define endmntent(x) ((int)1)
+
+#endif /* _MNTENT_H */
+#endif /* HAVE_MNTENT_H */
diff --git a/audio/ssr-lv2/files/patch-thirdparty_cpuid_platform_src_platform_config.hpp b/audio/ssr-lv2/files/patch-thirdparty_cpuid_platform_src_platform_config.hpp
new file mode 100644
index 000000000000..855f2b82bdee
--- /dev/null
+++ b/audio/ssr-lv2/files/patch-thirdparty_cpuid_platform_src_platform_config.hpp
@@ -0,0 +1,11 @@
+--- thirdparty/cpuid/platform/src/platform/config.hpp.orig 2021-09-23 02:15:16 UTC
++++ thirdparty/cpuid/platform/src/platform/config.hpp
+@@ -16,6 +16,8 @@
+ #if defined(__ANDROID__)
+ #define PLATFORM_ANDROID 1
+ #endif
++#elif defined(__FreeBSD__)
++ #define PLATFORM_FREEBSD 1
+ #elif defined(_WIN32)
+ #define PLATFORM_WINDOWS 1
+ #if defined(WINAPI_FAMILY)
diff --git a/audio/ssr-lv2/files/patch-thirdparty_cpuid_src_cpuid_cpuinfo.cpp b/audio/ssr-lv2/files/patch-thirdparty_cpuid_src_cpuid_cpuinfo.cpp
new file mode 100644
index 000000000000..3fd23a532d43
--- /dev/null
+++ b/audio/ssr-lv2/files/patch-thirdparty_cpuid_src_cpuid_cpuinfo.cpp
@@ -0,0 +1,11 @@
+--- thirdparty/cpuid/src/cpuid/cpuinfo.cpp.orig 2021-09-23 02:16:22 UTC
++++ thirdparty/cpuid/src/cpuid/cpuinfo.cpp
+@@ -16,7 +16,7 @@
+ #include "detail/init_msvc_arm.hpp"
+ #elif defined(PLATFORM_CLANG_ARM) && defined(PLATFORM_IOS)
+ #include "detail/init_ios_clang_arm.hpp"
+-#elif defined(PLATFORM_GCC_COMPATIBLE_ARM) && defined(PLATFORM_LINUX)
++#elif defined(PLATFORM_GCC_COMPATIBLE_ARM) && (defined(PLATFORM_LINUX) || defined(PLATFORM_FREEBSD))
+ #include "detail/init_linux_gcc_arm.hpp"
+ #else
+ #include "detail/init_unknown.hpp"
diff --git a/audio/ssr-lv2/pkg-descr b/audio/ssr-lv2/pkg-descr
new file mode 100644
index 000000000000..0e7dee4d1492
--- /dev/null
+++ b/audio/ssr-lv2/pkg-descr
@@ -0,0 +1,7 @@
+ssr is a sympathetic string resonator LV2 plugin.
+
+Sympathetic strings or resonance strings are auxiliary strings found on many
+Indian musical instruments, as well as some Western Baroque instruments and a
+variety of folk instruments.
+
+WWW: https://github.com/jpcima/ssr