aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:12 +0000
commit9d2cb17c9c0954773f2129da8fdaa5269a37f69f (patch)
treeb7606b6bd7abc4df228f6f0151fef929b55f7ca8
parentb9875ea5cbfe32d3a0f31c671a546c94c263789d (diff)
downloadports-9d2cb17c9c0954773f2129da8fdaa5269a37f69f.tar.gz
ports-9d2cb17c9c0954773f2129da8fdaa5269a37f69f.zip
devel/py-flit-core: Convert to USE_PYTHON=pytest
-rw-r--r--devel/py-flit-core/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/py-flit-core/Makefile b/devel/py-flit-core/Makefile
index e024fb09e3d3..4eea51d36fe5 100644
--- a/devel/py-flit-core/Makefile
+++ b/devel/py-flit-core/Makefile
@@ -12,18 +12,14 @@ COMMENT= Distribution-building parts of Flit
LICENSE= BSD3CLAUSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}testpath>=0:devel/py-testpath@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}testpath>=0:devel/py-testpath@${PY_FLAVOR}
USES= python:3.4+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
post-patch:
@${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-
.include <bsd.port.mk>