aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 14:52:49 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 14:52:49 +0000
commit9d2fa421ba2838665a5c055822001506558700df (patch)
tree28d1947105ecac1dac6c709e40d794c5804b3c1c
parent2637124dba2d68f94ba37fa3fa12780256d34a3b (diff)
downloadports-9d2fa421ba2838665a5c055822001506558700df.tar.gz
ports-9d2fa421ba2838665a5c055822001506558700df.zip
www/qt6-sensors: new port
This adds the missing Qt 6 sensors module to the tree. As with the rest of the Qt 6 ports, we first need to figure out what is actually required by other ports before we can finalize them.
-rw-r--r--Mk/Uses/qt-dist.mk2
-rw-r--r--Mk/Uses/qt.mk3
-rw-r--r--comms/Makefile1
-rw-r--r--comms/qt6-sensors/Makefile14
-rw-r--r--comms/qt6-sensors/distinfo3
-rw-r--r--comms/qt6-sensors/pkg-descr4
-rw-r--r--comms/qt6-sensors/pkg-plist199
7 files changed, 224 insertions, 2 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index fc9614e7ebde..416010c07020 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -29,7 +29,7 @@ _QT5_DISTS= 3d activeqt androidextras base charts connectivity datavis3d \
webchannel webengine webglplugin websockets webview winextras \
x11extras xmlpatterns
_QT6_DISTS= 3d 5compat base declarative doc imageformats multimedia quick3d quickcontrols2 \
- quicktimeline networkauth serialbus serialport shadertools svg tools \
+ quicktimeline networkauth sensors serialbus serialport shadertools svg tools \
translations virtualkeyboard webchannel webengine \
websockets webview wayland
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index abfa00feaaea..0d16ec3cc927 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -151,7 +151,8 @@ _USE_QT5_ONLY= 3d buildtools charts concurrent connectivity \
sql-sqlite3 svg testlib webkit xml xmlpatterns
_USE_QT6_ONLY= 3d 5compat base declarative doc imageformats quick3d \
- quickcontrols2 quicktimeline networkauth serialbus serialport shadertools \
+ quickcontrols2 quicktimeline networkauth sensors \
+ serialbus serialport shadertools \
svg tools translations wayland webchannel websockets
# Dependency tuples: _LIB should be preferred if possible.
diff --git a/comms/Makefile b/comms/Makefile
index 4d4dfd1a234f..3c67a58fc4b6 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -148,6 +148,7 @@
SUBDIR += qt5-sensors
SUBDIR += qt5-serialbus
SUBDIR += qt5-serialport
+ SUBDIR += qt6-sensors
SUBDIR += qt6-serialbus
SUBDIR += qt6-serialport
SUBDIR += qtel
diff --git a/comms/qt6-sensors/Makefile b/comms/qt6-sensors/Makefile
new file mode 100644
index 000000000000..21dff307286b
--- /dev/null
+++ b/comms/qt6-sensors/Makefile
@@ -0,0 +1,14 @@
+PORTNAME= sensors
+PORTVERSION= ${QT6_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt6-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt sensors module
+
+BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+
+USES= cmake compiler:c++11-lang pkgconfig qt-dist:6
+USE_QT= base declarative
+
+.include <bsd.port.mk>
diff --git a/comms/qt6-sensors/distinfo b/comms/qt6-sensors/distinfo
new file mode 100644
index 000000000000..9ac736220a73
--- /dev/null
+++ b/comms/qt6-sensors/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661179755
+SHA256 (KDE/Qt/6.3.1/qtsensors-everywhere-src-6.3.1.tar.xz) = 4b240b59edba9a42b4735758a25f279a26841b982864e7b38f6ef0b81e0d60cc
+SIZE (KDE/Qt/6.3.1/qtsensors-everywhere-src-6.3.1.tar.xz) = 2109248
diff --git a/comms/qt6-sensors/pkg-descr b/comms/qt6-sensors/pkg-descr
new file mode 100644
index 000000000000..03994646989d
--- /dev/null
+++ b/comms/qt6-sensors/pkg-descr
@@ -0,0 +1,4 @@
+The Qt Sensors module provides access to sensor hardware via QML and C++
+interfaces.
+
+https://qt.io
diff --git a/comms/qt6-sensors/pkg-plist b/comms/qt6-sensors/pkg-plist
new file mode 100644
index 000000000000..86a768342a2e
--- /dev/null
+++ b/comms/qt6-sensors/pkg-plist
@@ -0,0 +1,199 @@
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qaccelerometer_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qambientlightsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qambienttemperaturesensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qcompass_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qgyroscope_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qhumiditysensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qirproximitysensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qlidsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qlightsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qmagnetometer_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qorientationsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qpressuresensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qproximitysensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qrotationsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorbackend_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorgesture_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorgesturemanagerprivate_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qtapsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qtiltsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qtsensors-config_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/sensorlog_p.h
+%%QT_INCDIR%%/QtSensors/QAccelerometer
+%%QT_INCDIR%%/QtSensors/QAccelerometerFilter
+%%QT_INCDIR%%/QtSensors/QAccelerometerReading
+%%QT_INCDIR%%/QtSensors/QAmbientLightFilter
+%%QT_INCDIR%%/QtSensors/QAmbientLightReading
+%%QT_INCDIR%%/QtSensors/QAmbientLightSensor
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureFilter
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureReading
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureSensor
+%%QT_INCDIR%%/QtSensors/QCompass
+%%QT_INCDIR%%/QtSensors/QCompassFilter
+%%QT_INCDIR%%/QtSensors/QCompassReading
+%%QT_INCDIR%%/QtSensors/QGyroscope
+%%QT_INCDIR%%/QtSensors/QGyroscopeFilter
+%%QT_INCDIR%%/QtSensors/QGyroscopeReading
+%%QT_INCDIR%%/QtSensors/QHumidityFilter
+%%QT_INCDIR%%/QtSensors/QHumidityReading
+%%QT_INCDIR%%/QtSensors/QHumiditySensor
+%%QT_INCDIR%%/QtSensors/QIRProximityFilter
+%%QT_INCDIR%%/QtSensors/QIRProximityReading
+%%QT_INCDIR%%/QtSensors/QIRProximitySensor
+%%QT_INCDIR%%/QtSensors/QLidFilter
+%%QT_INCDIR%%/QtSensors/QLidReading
+%%QT_INCDIR%%/QtSensors/QLidSensor
+%%QT_INCDIR%%/QtSensors/QLightFilter
+%%QT_INCDIR%%/QtSensors/QLightReading
+%%QT_INCDIR%%/QtSensors/QLightSensor
+%%QT_INCDIR%%/QtSensors/QMagnetometer
+%%QT_INCDIR%%/QtSensors/QMagnetometerFilter
+%%QT_INCDIR%%/QtSensors/QMagnetometerReading
+%%QT_INCDIR%%/QtSensors/QOrientationFilter
+%%QT_INCDIR%%/QtSensors/QOrientationReading
+%%QT_INCDIR%%/QtSensors/QOrientationSensor
+%%QT_INCDIR%%/QtSensors/QPressureFilter
+%%QT_INCDIR%%/QtSensors/QPressureReading
+%%QT_INCDIR%%/QtSensors/QPressureSensor
+%%QT_INCDIR%%/QtSensors/QProximityFilter
+%%QT_INCDIR%%/QtSensors/QProximityReading
+%%QT_INCDIR%%/QtSensors/QProximitySensor
+%%QT_INCDIR%%/QtSensors/QRotationFilter
+%%QT_INCDIR%%/QtSensors/QRotationReading
+%%QT_INCDIR%%/QtSensors/QRotationSensor
+%%QT_INCDIR%%/QtSensors/QSensor
+%%QT_INCDIR%%/QtSensors/QSensorBackend
+%%QT_INCDIR%%/QtSensors/QSensorBackendFactory
+%%QT_INCDIR%%/QtSensors/QSensorChangesInterface
+%%QT_INCDIR%%/QtSensors/QSensorFilter
+%%QT_INCDIR%%/QtSensors/QSensorGesture
+%%QT_INCDIR%%/QtSensors/QSensorGestureManager
+%%QT_INCDIR%%/QtSensors/QSensorGesturePluginInterface
+%%QT_INCDIR%%/QtSensors/QSensorGestureRecognizer
+%%QT_INCDIR%%/QtSensors/QSensorManager
+%%QT_INCDIR%%/QtSensors/QSensorPluginInterface
+%%QT_INCDIR%%/QtSensors/QSensorReading
+%%QT_INCDIR%%/QtSensors/QTapFilter
+%%QT_INCDIR%%/QtSensors/QTapReading
+%%QT_INCDIR%%/QtSensors/QTapSensor
+%%QT_INCDIR%%/QtSensors/QTiltFilter
+%%QT_INCDIR%%/QtSensors/QTiltReading
+%%QT_INCDIR%%/QtSensors/QTiltSensor
+%%QT_INCDIR%%/QtSensors/QtSensors
+%%QT_INCDIR%%/QtSensors/QtSensorsDepends
+%%QT_INCDIR%%/QtSensors/QtSensorsVersion
+%%QT_INCDIR%%/QtSensors/qaccelerometer.h
+%%QT_INCDIR%%/QtSensors/qambientlightsensor.h
+%%QT_INCDIR%%/QtSensors/qambienttemperaturesensor.h
+%%QT_INCDIR%%/QtSensors/qcompass.h
+%%QT_INCDIR%%/QtSensors/qgyroscope.h
+%%QT_INCDIR%%/QtSensors/qhumiditysensor.h
+%%QT_INCDIR%%/QtSensors/qirproximitysensor.h
+%%QT_INCDIR%%/QtSensors/qlidsensor.h
+%%QT_INCDIR%%/QtSensors/qlightsensor.h
+%%QT_INCDIR%%/QtSensors/qmagnetometer.h
+%%QT_INCDIR%%/QtSensors/qorientationsensor.h
+%%QT_INCDIR%%/QtSensors/qpressuresensor.h
+%%QT_INCDIR%%/QtSensors/qproximitysensor.h
+%%QT_INCDIR%%/QtSensors/qrotationsensor.h
+%%QT_INCDIR%%/QtSensors/qsensor.h
+%%QT_INCDIR%%/QtSensors/qsensorbackend.h
+%%QT_INCDIR%%/QtSensors/qsensorgesture.h
+%%QT_INCDIR%%/QtSensors/qsensorgesturemanager.h
+%%QT_INCDIR%%/QtSensors/qsensorgestureplugininterface.h
+%%QT_INCDIR%%/QtSensors/qsensorgesturerecognizer.h
+%%QT_INCDIR%%/QtSensors/qsensormanager.h
+%%QT_INCDIR%%/QtSensors/qsensorplugin.h
+%%QT_INCDIR%%/QtSensors/qsensorsglobal.h
+%%QT_INCDIR%%/QtSensors/qtapsensor.h
+%%QT_INCDIR%%/QtSensors/qtiltsensor.h
+%%QT_INCDIR%%/QtSensors/qtsensors-config.h
+%%QT_INCDIR%%/QtSensors/qtsensorsexports.h
+%%QT_INCDIR%%/QtSensors/qtsensorsversion.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlaccelerometer_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlambientlightsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlambienttemperaturesensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlcompass_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlgyroscope_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlhumiditysensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlirproximitysensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmllidsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmllightsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlmagnetometer_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlorientationsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlpressuresensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlproximitysensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlrotationsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlsensorgesture_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlsensorglobal_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmlsensorrange_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmltapsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qmltiltsensor_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qsensorsquickglobal_p.h
+%%QT_INCDIR%%/QtSensorsQuick/%%FULLVER%%/QtSensorsQuick/private/qtsensorsquickexports_p.h
+%%QT_INCDIR%%/QtSensorsQuick/QtSensorsQuick
+%%QT_INCDIR%%/QtSensorsQuick/QtSensorsQuickDepends
+%%QT_INCDIR%%/QtSensorsQuick/QtSensorsQuickVersion
+%%QT_INCDIR%%/QtSensorsQuick/qtsensorsquickexports.h
+%%QT_INCDIR%%/QtSensorsQuick/qtsensorsquickversion.h
+lib/cmake/Qt6/FindSensorfw.cmake
+lib/cmake/Qt6BuildInternals/StandaloneTests/QtSensorsTestsConfig.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginAdditionalTargetInfo.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginConfig.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginConfigVersion.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginConfigVersionImpl.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Qml/QmlPlugins/Qt6SensorsQuickpluginTargets.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsAdditionalTargetInfo.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsConfig.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsConfigVersion.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsConfigVersionImpl.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsDependencies.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsTargets.cmake
+lib/cmake/Qt6Sensors/Qt6SensorsVersionlessTargets.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginAdditionalTargetInfo.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginConfig.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginConfigVersion.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginConfigVersionImpl.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Sensors/Qt6dummySensorPluginTargets.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginAdditionalTargetInfo.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginConfig.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginConfigVersion.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginConfigVersionImpl.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Sensors/Qt6genericSensorPluginTargets.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickAdditionalTargetInfo.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickConfig.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickConfigVersion.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickConfigVersionImpl.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickDependencies.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickTargets.cmake
+lib/cmake/Qt6SensorsQuick/Qt6SensorsQuickVersionlessTargets.cmake
+%%QT_LIBDIR%%/libQt6Sensors.prl
+%%QT_LIBDIR%%/libQt6Sensors.so
+%%QT_LIBDIR%%/libQt6Sensors.so.6
+%%QT_LIBDIR%%/libQt6Sensors.so.%%FULLVER%%
+%%QT_LIBDIR%%/libQt6SensorsQuick.prl
+%%QT_LIBDIR%%/libQt6SensorsQuick.so
+%%QT_LIBDIR%%/libQt6SensorsQuick.so.6
+%%QT_LIBDIR%%/libQt6SensorsQuick.so.%%FULLVER%%
+%%QT_LIBDIR%%/metatypes/qt6sensors_%%CMAKE_BUILD_TYPE%%_metatypes.json
+%%QT_LIBDIR%%/metatypes/qt6sensorsquick_%%CMAKE_BUILD_TYPE%%_metatypes.json
+%%QT_MKSPECDIR%%/modules/qt_lib_sensors.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_sensors_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_sensorsquick.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_sensorsquick_private.pri
+%%QT_PLUGINDIR%%/sensors/libqtsensors_dummy.so
+%%QT_PLUGINDIR%%/sensors/libqtsensors_generic.so
+%%QT_QMLDIR%%/QtSensors/libsensorsquickplugin.so
+%%QT_QMLDIR%%/QtSensors/plugins.qmltypes
+%%QT_QMLDIR%%/QtSensors/qmldir
+libdata/pkgconfig/Qt6Sensors.pc
+libdata/pkgconfig/Qt6SensorsQuick.pc
+%%QT_DATADIR%%/modules/Sensors.json
+%%QT_DATADIR%%/modules/SensorsQuick.json