aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 16:04:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 16:11:01 +0000
commit9d7189cea4d78e95f8dc3c0429d1f58b80d0b134 (patch)
treecf66685e4ee0372f0a09e4a7b4f9d3fd80fa109f
parent80fb01f4d51d70c857e2b3c276a19a00f2c6b24a (diff)
downloadports-9d7189cea4d78e95f8dc3c0429d1f58b80d0b134.tar.gz
ports-9d7189cea4d78e95f8dc3c0429d1f58b80d0b134.zip
security/py-bcrypt: Fix *_DEPENDS: Remove py-six
- Update WWW - Convert to USE_PYTHON=pep517 - Convert to USE_PYTHON=pytest - Bump PORTREVISION for dependency and package change
-rw-r--r--security/py-bcrypt/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/security/py-bcrypt/Makefile b/security/py-bcrypt/Makefile
index bd66e5cfb2ad..3feb92600cb8 100644
--- a/security/py-bcrypt/Makefile
+++ b/security/py-bcrypt/Makefile
@@ -1,29 +1,28 @@
PORTNAME= bcrypt
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= Modern password hashing for your software and your servers
-WWW= https://github.com/pyca/bcrypt/
+WWW= https://github.com/pyca/bcrypt
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.2.1:devel/py-pytest@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=42.0.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1:devel/py-cffi@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517 pytest
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/bcrypt/_bcrypt*.so
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>