aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-12-19 07:12:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-12-19 07:39:04 +0000
commit9d8965f8adb9a38c5fcf53409110dbb8fa903bcb (patch)
tree7df30ed1df1dfc6449e305611782c0bb26329cb9
parenta225f1c824a60e23c2d12278256d46362bf024d8 (diff)
downloadports-9d8965f8adb9a38c5fcf53409110dbb8fa903bcb.tar.gz
ports-9d8965f8adb9a38c5fcf53409110dbb8fa903bcb.zip
x11/swaysettings: add new port
SwaySettings is a GUI for configuring your Sway desktop. Features: - Set and remove auto start apps - Change default apps - Change GTK theme (GTK 3 and potentially GTK 2) - Mouse and trackpad settings - Keyboard layout settings - Switch Wallpaper (selected wallpaper will be located at .cache/wallpaper) - Configure Sway Notification Center https://github.com/ErikReider/SwaySettings
-rw-r--r--x11/Makefile1
-rw-r--r--x11/swaysettings/Makefile33
-rw-r--r--x11/swaysettings/distinfo3
-rw-r--r--x11/swaysettings/pkg-descr12
-rw-r--r--x11/swaysettings/pkg-plist7
5 files changed, 56 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 87a2d1c53e85..6f29ee6c6d58 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -351,6 +351,7 @@
SUBDIR += swaylock-effects
SUBDIR += swaync
SUBDIR += swayr
+ SUBDIR += swaysettings
SUBDIR += sxhkd
SUBDIR += sxpc
SUBDIR += tabbed
diff --git a/x11/swaysettings/Makefile b/x11/swaysettings/Makefile
new file mode 100644
index 000000000000..f76e03aa7c83
--- /dev/null
+++ b/x11/swaysettings/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= swaysettings
+PORTVERSION= s20211118
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GUI for setting Sway wallpaper, default apps, GTK themes, etc.
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
+ libgee-0.8.so:devel/libgee \
+ libaccountsservice.so:sysutils/accountsservice \
+ libgranite.so:x11-toolkits/granite \
+ libhandy-1.so:x11-toolkits/libhandy
+
+USES= compiler:c11 gettext gnome meson pkgconfig python:build shebangfix
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2
+GH_ACCOUNT= ErikReider
+GH_PROJECT= SwaySettings
+GH_TAGNAME= 13212aa
+SHEBANG_FILES= build-aux/meson/postinstall.py
+
+post-patch:
+# Respect PREFIX for images and XKB layouts
+ @${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
+ ${WRKSRC}/src/Page/Input_Page.vala \
+ ${WRKSRC}/src/Pages/Background/Background_Page.vala \
+ ${WRKSRC}/src/Pages/Users/Users.vala
+
+.include <bsd.port.mk>
diff --git a/x11/swaysettings/distinfo b/x11/swaysettings/distinfo
new file mode 100644
index 000000000000..bc4fa8090ecf
--- /dev/null
+++ b/x11/swaysettings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637244061
+SHA256 (ErikReider-SwaySettings-s20211118-13212aa_GH0.tar.gz) = 33732a0c13981eb8c1116aef4f4c8e7c6a7c9511a660bb7f58ca11fb212a52a2
+SIZE (ErikReider-SwaySettings-s20211118-13212aa_GH0.tar.gz) = 74436
diff --git a/x11/swaysettings/pkg-descr b/x11/swaysettings/pkg-descr
new file mode 100644
index 000000000000..3d948368085b
--- /dev/null
+++ b/x11/swaysettings/pkg-descr
@@ -0,0 +1,12 @@
+SwaySettings is a GUI for configuring your Sway desktop.
+
+Features:
+- Set and remove auto start apps
+- Change default apps
+- Change GTK theme (GTK 3 and potentially GTK 2)
+- Mouse and trackpad settings
+- Keyboard layout settings
+- Switch Wallpaper (selected wallpaper will be located at .cache/wallpaper)
+- Configure Sway Notification Center
+
+WWW: https://github.com/ErikReider/SwaySettings
diff --git a/x11/swaysettings/pkg-plist b/x11/swaysettings/pkg-plist
new file mode 100644
index 000000000000..a0982bb6e273
--- /dev/null
+++ b/x11/swaysettings/pkg-plist
@@ -0,0 +1,7 @@
+bin/sway-autostart
+bin/swaysettings
+share/appdata/org.erikreider.swaysettings.appdata.xml
+share/applications/org.erikreider.swaysettings.desktop
+share/glib-2.0/schemas/org.erikreider.swaysettings.gschema.xml
+share/icons/hicolor/scalable/apps/org.erikreider.swaysettings.svg
+share/icons/hicolor/symbolic/apps/org.erikreider.swaysettings-symbolic.svg