aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 17:51:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 18:00:40 +0000
commit9e1851791078cb61becf7daeec1ff3f9926d1019 (patch)
tree764f8f8d3de7388a3955d41d74e5d478c93ce65a
parent30dd3d5abda0a5df19c9787b783f8ea0538f124f (diff)
downloadports-9e1851791078cb61becf7daeec1ff3f9926d1019.tar.gz
ports-9e1851791078cb61becf7daeec1ff3f9926d1019.zip
devel/py-anndata: Add py-anndata 0.9.1
anndata is a Python package for handling annotated data matrices in memory and on disk, positioned between pandas and xarray. anndata offers a broad range of computationally efficient features including, among others, sparse data support, lazy operations, and a PyTorch interface.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-anndata/Makefile33
-rw-r--r--devel/py-anndata/distinfo3
-rw-r--r--devel/py-anndata/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a4be7c892aae..07843d08f3da 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4179,6 +4179,7 @@
SUBDIR += py-amalgamate
SUBDIR += py-aniso8601
SUBDIR += py-aniso86016
+ SUBDIR += py-anndata
SUBDIR += py-ansi
SUBDIR += py-antlr4-python3-runtime
SUBDIR += py-anyconfig
diff --git a/devel/py-anndata/Makefile b/devel/py-anndata/Makefile
new file mode 100644
index 000000000000..b99c2fc55aa2
--- /dev/null
+++ b/devel/py-anndata/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= anndata
+PORTVERSION= 0.9.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Annotated data
+WWW= https://github.com/scverse/anndata
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>=3:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}natsort>=0:devel/py-natsort@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.16.5,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=1.1.1,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.4:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h5py>=3:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}natsort>=0:devel/py-natsort@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.16.5,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=1.1.1,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.4:science/py-scipy@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-anndata/distinfo b/devel/py-anndata/distinfo
new file mode 100644
index 000000000000..415ac88ce684
--- /dev/null
+++ b/devel/py-anndata/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681052882
+SHA256 (anndata-0.9.1.tar.gz) = 1f28f2c427e67b0b99bdd2b281717c92a12660dfd23e0694939b6e733f0eb2c4
+SIZE (anndata-0.9.1.tar.gz) = 91677
diff --git a/devel/py-anndata/pkg-descr b/devel/py-anndata/pkg-descr
new file mode 100644
index 000000000000..9b3cf7b93356
--- /dev/null
+++ b/devel/py-anndata/pkg-descr
@@ -0,0 +1,4 @@
+anndata is a Python package for handling annotated data matrices in memory and
+on disk, positioned between pandas and xarray. anndata offers a broad range of
+computationally efficient features including, among others, sparse data support,
+lazy operations, and a PyTorch interface.