aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-02 06:45:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-02 06:52:31 +0000
commit9ea1c4642797c6c798ca562e614d4c383dd5869b (patch)
tree5d1ecf8343b7fdacc4f519b063715be5f58ce399
parentdb1512a686f5b5c32eac9eae1f81ce142e6990b6 (diff)
downloadports-9ea1c4642797c6c798ca562e614d4c383dd5869b.tar.gz
ports-9ea1c4642797c6c798ca562e614d4c383dd5869b.zip
x11/mako: unbreak icon search
Example: $ notify-send --icon=mpv song.mp3
-rw-r--r--x11/mako/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11/mako/Makefile b/x11/mako/Makefile
index 735ed6d8a0f0..ecf6e6d273ec 100644
--- a/x11/mako/Makefile
+++ b/x11/mako/Makefile
@@ -1,6 +1,7 @@
PORTNAME= mako
DISTVERSIONPREFIX= v
DISTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
@@ -36,4 +37,10 @@ MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
PIXBUF_USE= GNOME=gdkpixbuf2
PIXBUF_MESON_ENABLED= icons
+post-patch:
+# Respect PREFIX for icons
+ @${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},g' \
+ ${WRKSRC}/icon.c \
+ ${WRKSRC}/${PORTNAME}.5.scd
+
.include <bsd.port.mk>