aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-09-16 13:08:00 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-09-16 13:10:36 +0000
commita054ac48dddb63f5a2995d279d56700f90306369 (patch)
tree1f03ec54302926f24992ed7f7ed58e46dcfd9299
parent16aabfb235441e4c0f6ec7c6643b4a343b7e2a14 (diff)
downloadports-a054ac48dddb63f5a2995d279d56700f90306369.tar.gz
ports-a054ac48dddb63f5a2995d279d56700f90306369.zip
security/libressl: Use CA bundle from base
PR: 269473 Reported by: tijl
-rw-r--r--security/libressl-devel/Makefile3
-rw-r--r--security/libressl-devel/pkg-plist2
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/libressl/pkg-plist2
4 files changed, 8 insertions, 2 deletions
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 8c4574f9c5be..be23b1c50546 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libressl
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
PKGNAMESUFFIX= -devel
@@ -63,6 +64,8 @@ post-patch-MAN3-off:
post-install:
${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+ ${RMDIR} ${STAGEDIR}${PREFIX}/etc/ssl/certs
+ ${LN} -s /etc/ssl/certs ${STAGEDIR}${PREFIX}/etc/ssl/certs
post-stage-MAN3-on:
(cd ${STAGEDIR}${MANPREFIX}; ${FIND} man/man3 -not -type d | \
diff --git a/security/libressl-devel/pkg-plist b/security/libressl-devel/pkg-plist
index cea443dd8a1b..2488b44377ce 100644
--- a/security/libressl-devel/pkg-plist
+++ b/security/libressl-devel/pkg-plist
@@ -1,6 +1,7 @@
%%NC%%bin/nc
bin/ocspcheck
bin/openssl
+etc/ssl/certs
etc/ssl/openssl.cnf
etc/ssl/x509v3.cnf
include/openssl/aes.h
@@ -98,5 +99,4 @@ man/man1/openssl.1.gz
man/man5/openssl.cnf.5.gz
man/man5/x509v3.cnf.5.gz
man/man8/ocspcheck.8.gz
-@dir etc/ssl/certs
@dir include/openssl
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 2807e6ff01ab..ee7101d2e1b8 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libressl
PORTVERSION= 3.7.3
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
@@ -64,6 +65,8 @@ post-patch-MAN3-off:
post-install:
${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+ ${RMDIR} ${STAGEDIR}${PREFIX}/etc/ssl/certs
+ ${LN} -s /etc/ssl/certs ${STAGEDIR}${PREFIX}/etc/ssl/certs
post-stage-MAN3-on:
(cd ${STAGEDIR}${MANPREFIX}; ${FIND} man/man3 -not -type d | \
diff --git a/security/libressl/pkg-plist b/security/libressl/pkg-plist
index 2715748487d7..87dc9091f155 100644
--- a/security/libressl/pkg-plist
+++ b/security/libressl/pkg-plist
@@ -1,6 +1,7 @@
%%NC%%bin/nc
bin/ocspcheck
bin/openssl
+etc/ssl/certs
etc/ssl/openssl.cnf
etc/ssl/x509v3.cnf
include/openssl/aes.h
@@ -99,5 +100,4 @@ man/man1/openssl.1.gz
man/man5/openssl.cnf.5.gz
man/man5/x509v3.cnf.5.gz
man/man8/ocspcheck.8.gz
-@dir etc/ssl/certs
@dir include/openssl