aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-20 09:14:00 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-04 08:56:25 +0000
commita10fc0f8f94de7875cdd7ce09b931ee14f6f004b (patch)
treee786faa01248cd5dbeb0471d2eece67515379af2
parentad51d83d0c1f79bf52e0ab4319022fbf367ecba2 (diff)
downloadports-a10fc0f8f94de7875cdd7ce09b931ee14f6f004b.tar.gz
ports-a10fc0f8f94de7875cdd7ce09b931ee14f6f004b.zip
devel/intel-graphics-compiler: update to 1.0.8173
-rw-r--r--devel/intel-graphics-compiler/Makefile11
-rw-r--r--devel/intel-graphics-compiler/distinfo16
-rw-r--r--devel/intel-graphics-compiler/files/patch-llvm11115
-rw-r--r--devel/intel-graphics-compiler/files/patch-unix26
-rw-r--r--devel/intel-graphics-compiler/pkg-plist1
5 files changed, 34 insertions, 135 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index 6a5ee188c8bd..7e5935ba28cd 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -1,8 +1,13 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.7041
+DISTVERSION= 1.0.8173
CATEGORIES= devel
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= b7f29ee948b9.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
+PATCHFILES+= a69ee09275fe.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
+PATCHFILES+= 12c4fbc2b511.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Intel Graphics Compiler for OpenCL
@@ -18,7 +23,7 @@ USES= bison cmake compiler:c++17-lang python:build
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= intel
-GH_TUPLE= intel:vc-intrinsics:069ced1:vcintrin/../vc-intrinsics
+GH_TUPLE= intel:vc-intrinsics:05d3f3d:vcintrin/../vc-intrinsics
CMAKE_OFF= INSTALL_SPIRVDLL
CFLAGS+= -Wno-macro-redefined # __fastcall
PLIST_SUB= ARCH_SUFX=${ARCH:S/i386/32/:S/amd//:S/x86_//}
@@ -32,6 +37,8 @@ post-patch:
${WRKSRC}/IGC/BiFModule/linux/CMakeLists.txt
# devel/llvm* have different naming from upstream under PATH
@${REINPLACE_CMD} -e '/clang-\$$/s//clang$$/' \
+ -e '/llvm-\$$/s//llvm$$/' \
+ ${WRKSRC}/IGC/cmake/igc_find_liblldELF.cmake \
${WRKSRC}/IGC/cmake/igc_find_opencl_clang.cmake
# No need to abort on every benign warning enabled by default
@${REINPLACE_CMD} -e 's/"-Werror"//; /-Werror/d' \
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index 99c09654eeae..c4a07aa66e33 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,5 +1,11 @@
-TIMESTAMP = 1617824048
-SHA256 (intel-intel-graphics-compiler-igc-1.0.7041_GH0.tar.gz) = 299494ff885c8f0452c250867586be937a1aff9d46e6ff61a954bfc1e3a3c406
-SIZE (intel-intel-graphics-compiler-igc-1.0.7041_GH0.tar.gz) = 7470694
-SHA256 (intel-vc-intrinsics-069ced1_GH0.tar.gz) = f64cae99ad5a7c31c7ee7403d139be2654b4c6b08e21dd8db3feef939463652f
-SIZE (intel-vc-intrinsics-069ced1_GH0.tar.gz) = 124312
+TIMESTAMP = 1626602428
+SHA256 (intel-intel-graphics-compiler-igc-1.0.8173_GH0.tar.gz) = 20794f1451b971c82ed824dd65723a6c562158e8061644e596b53417e9daa045
+SIZE (intel-intel-graphics-compiler-igc-1.0.8173_GH0.tar.gz) = 7471884
+SHA256 (intel-vc-intrinsics-05d3f3d_GH0.tar.gz) = 7d3df322a91ea9d95ef606b9d5a2580d6deb426f779ba921ae3a799a5e642c4f
+SIZE (intel-vc-intrinsics-05d3f3d_GH0.tar.gz) = 126560
+SHA256 (b7f29ee948b9.patch) = f47c5d7b37d4ae264eef37646afbcbaadd370ad91035895630bd52da7cf82452
+SIZE (b7f29ee948b9.patch) = 1199
+SHA256 (a69ee09275fe.patch) = e3f293844338d50e6c6d8f0213377637dc1eefc79bfd07c92e889ed8a8d8dd1f
+SIZE (a69ee09275fe.patch) = 1160
+SHA256 (12c4fbc2b511.patch) = e7570987a542f8688641b2172c87f75de0b114cde6d083f21ef27431193e648c
+SIZE (12c4fbc2b511.patch) = 4376
diff --git a/devel/intel-graphics-compiler/files/patch-llvm11 b/devel/intel-graphics-compiler/files/patch-llvm11
deleted file mode 100644
index 6ff712a80272..000000000000
--- a/devel/intel-graphics-compiler/files/patch-llvm11
+++ /dev/null
@@ -1,115 +0,0 @@
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:156:35: error: no member named 'getVectorElementType' in 'llvm::Type'; did you mean 'getPointerElementType'?
- ldmcs->getType()->getVectorElementType() == m_builder->getInt32Ty())
- ^~~~~~~~~~~~~~~~~~~~
- getPointerElementType
-/usr/local/llvm11/include/llvm/IR/Type.h:370:9: note: 'getPointerElementType' declared here
- Type *getPointerElementType() const {
- ^
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:160:61: error: no member named 'getVectorNumElements' in 'llvm::Type'
- uint ldmcsNumOfElements = ldmcs->getType()->getVectorNumElements();
- ~~~~~~~~~~~~~~~~ ^
-IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp:161:71: error: no member named 'getVectorNumElements' in 'llvm::Type'
- uint newLdmcsNumOfElements = new_mcs_call->getType()->getVectorNumElements();
- ~~~~~~~~~~~~~~~~~~~~~~~ ^
-
-IGC/Compiler/Legalizer/InstPromoter.cpp:402:42: error: no member named 'getVectorNumElements' in 'llvm::Type'
- for (unsigned i = 0; i < DestTy->getVectorNumElements(); i++)
- ~~~~~~ ^
-
-IGC/Compiler/Optimizer/OpenCLPasses/WIFuncs/WIFuncResolution.cpp:308:27: error: no member named 'getVectorNumElements' in 'llvm::Type'
- Size *= DataType->getVectorNumElements();
- ~~~~~~~~ ^
-
-IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp:528:33: error: no viable conversion from 'llvm::StringRef' to 'const std::string' (aka 'const basic_string<char, char_traits<char>, allocator<char>>')
- auto *VF = VB.GetVISAKernel(F->getName());
- ^~~~~~~~~~~~
-IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp:2203:5: error: no matching function for call to 'RecursivelyDeleteTriviallyDeadInstructions'
- RecursivelyDeleteTriviallyDeadInstructions(ToErase);
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-/usr/local/llvm11/include/llvm/Transforms/Utils/Local.h:161:6: note: candidate function not viable: no known conversion from 'SmallVector<llvm::Instruction *, 8>' to 'llvm::Value *' for 1st argument
-bool RecursivelyDeleteTriviallyDeadInstructions(
- ^
-/usr/local/llvm11/include/llvm/Transforms/Utils/Local.h:173:6: note: candidate function not viable: no known conversion from 'SmallVector<llvm::Instruction *, 8>' to 'SmallVectorImpl<llvm::WeakTrackingVH> &' for 1st argument
-void RecursivelyDeleteTriviallyDeadInstructions(
- ^
-
---- IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp.orig 2021-03-22 09:55:24 UTC
-+++ IGC/Compiler/ConvertMSAAPayloadTo16Bit.cpp
-@@ -153,12 +153,21 @@ void ConvertMSAAPayloadTo16Bit::visitCallInst(CallInst
- // There are uses of ldmcs other then ldms, using vector of int32 type.
- // Fix them to use newly created 16bit ldmcs.
- if (ldmcs->getType()->isVectorTy() &&
-+#if LLVM_VERSION_MAJOR < 11
- ldmcs->getType()->getVectorElementType() == m_builder->getInt32Ty())
-+#else
-+ cast<llvm::VectorType>(ldmcs->getType())->getElementType() == m_builder->getInt32Ty())
-+#endif
- {
- m_builder->SetInsertPoint(ldmcs);
-
-+#if LLVM_VERSION_MAJOR < 11
- uint ldmcsNumOfElements = ldmcs->getType()->getVectorNumElements();
- uint newLdmcsNumOfElements = new_mcs_call->getType()->getVectorNumElements();
-+#else
-+ uint ldmcsNumOfElements = cast<llvm::VectorType>(ldmcs->getType())->getNumElements();
-+ uint newLdmcsNumOfElements = cast<llvm::VectorType>(new_mcs_call->getType())->getNumElements();
-+#endif
-
- // vec of 16bit ints to vec of 32bit ints
- Type* newLdmcsVecType = VectorType::get(m_builder->getInt32Ty(), newLdmcsNumOfElements);
---- IGC/Compiler/Legalizer/InstPromoter.cpp.orig 2021-02-08 08:48:29 UTC
-+++ IGC/Compiler/Legalizer/InstPromoter.cpp
-@@ -399,7 +399,11 @@ bool InstPromoter::visitBitCastInst(BitCastInst& I) {
- IRB->CreateBitCast(Val, VectorType::get(DestTy->getScalarType(), N));
-
- std::vector<Constant*> Vals;
-+#if LLVM_VERSION_MAJOR < 11
- for (unsigned i = 0; i < DestTy->getVectorNumElements(); i++)
-+#else
-+ for (unsigned i = 0; i < cast<llvm::VectorType>(DestTy)->getNumElements(); i++)
-+#endif
- Vals.push_back(IRB->getInt32(i));
-
- Value* Mask = ConstantVector::get(Vals);
---- IGC/Compiler/Optimizer/OpenCLPasses/WIFuncs/WIFuncResolution.cpp.orig 2021-02-07 09:58:11 UTC
-+++ IGC/Compiler/Optimizer/OpenCLPasses/WIFuncs/WIFuncResolution.cpp
-@@ -305,7 +305,11 @@ static Value* BuildLoadInst(CallInst& CI, unsigned int
- auto Size = ElemByteSize;
- if (DataType->isVectorTy())
- {
-+#if LLVM_VERSION_MAJOR < 11
- Size *= DataType->getVectorNumElements();
-+#else
-+ Size *= cast<llvm::VectorType>(DataType)->getNumElements();
-+#endif
- }
- unsigned int AlignedOffset = (Offset / ElemByteSize) * ElemByteSize;
- unsigned int LoadByteSize = (Offset == AlignedOffset) ? Size : Size * 2;
---- IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp.orig 2021-03-28 09:45:11 UTC
-+++ IGC/VectorCompiler/lib/GenXCodeGen/GenXDebugInfo.cpp
-@@ -525,7 +525,11 @@ void GenXDebugInfo::processFunctionGroup(GenXModule &G
- for (auto *F : IndirectlyCalledFunctions) {
- LLVM_DEBUG(dbgs() << " F: " << F->getName() << " called indirectly!\n");
- // Each indirectly-called function is compiled into a separate vISA kernel
-+#if LLVM_VERSION_MAJOR < 11
- auto *VF = VB.GetVISAKernel(F->getName());
-+#else
-+ auto *VF = VB.GetVISAKernel(F->getName().str());
-+#endif
- processKernel(ProgramInfo{{BuildFunctionInfo(VF, F)}});
- }
- std::vector<ProgramInfo::FunctionInfo> PrimaryFIs;
---- IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp.orig 2021-02-15 09:29:30 UTC
-+++ IGC/VectorCompiler/lib/GenXCodeGen/GenXPatternMatch.cpp
-@@ -2194,7 +2194,11 @@ bool GenXPatternMatch::simplifySelect(Function *F) {
-
- bool GenXPatternMatch::clearDeadInstructions(Function &F) {
- bool Changed = false;
-+#if LLVM_VERSION_MAJOR < 11
- SmallVector<Instruction *, 8> ToErase;
-+#else
-+ SmallVector<WeakTrackingVH, 8> ToErase;
-+#endif
- for (auto &Inst : instructions(F))
- if (isInstructionTriviallyDead(&Inst))
- ToErase.push_back(&Inst);
diff --git a/devel/intel-graphics-compiler/files/patch-unix b/devel/intel-graphics-compiler/files/patch-unix
index d6dbb2e61eb2..ef8ba7e0a533 100644
--- a/devel/intel-graphics-compiler/files/patch-unix
+++ b/devel/intel-graphics-compiler/files/patch-unix
@@ -184,9 +184,9 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
if (!FCL_IGC_IS_FLAG_ENABLED(DumpToCurrentDir) && g_shaderOutputFolder == "" && !FCL_IGC_IS_FLAG_ENABLED(DumpToCustomDir))
{
bool needMkdir = true;
---- IGC/VectorCompiler/lib/GenXCodeGen/SPIRVWrapper.cpp.orig 2021-03-08 06:23:56 UTC
-+++ IGC/VectorCompiler/lib/GenXCodeGen/SPIRVWrapper.cpp
-@@ -48,7 +48,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+--- IGC/VectorCompiler/lib/Driver/SPIRVWrapper.cpp.orig 2021-04-20 09:14:00 UTC
++++ IGC/VectorCompiler/lib/Driver/SPIRVWrapper.cpp
+@@ -47,7 +47,7 @@ IN THE SOFTWARE.
#include "llvm/Support/DynamicLibrary.h"
#include "llvm/Support/Path.h"
#include "llvm/Support/Process.h"
@@ -195,7 +195,7 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
#include <dlfcn.h>
#endif // __linux__
#if defined(_WIN32)
-@@ -172,7 +172,7 @@ Expected<SpirvReadVerifyType *> getSpirvReadVerifyFunc
+@@ -171,7 +171,7 @@ Expected<SpirvReadVerifyType *> getSpirvReadVerifyFunc
constexpr char *SpirvReadVerifyName = "spirv_read_verify_module";
const std::string SpirvLibPath = findSpirvDLL();
@@ -204,9 +204,9 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
// Hack to workaround cmoc crashes during loading of SPIRV library
static auto DeepBindHack =
dlopen(SpirvLibPath.c_str(), RTLD_NOW | RTLD_DEEPBIND);
---- IGC/common/LLVMWarningsPop.hpp.orig 2019-11-27 01:05:20 UTC
+--- IGC/common/LLVMWarningsPop.hpp.orig 2021-05-12 10:04:39 UTC
+++ IGC/common/LLVMWarningsPop.hpp
-@@ -58,6 +58,6 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+@@ -41,6 +41,6 @@ SPDX-License-Identifier: MIT
# pragma warning( pop )
#endif
@@ -236,23 +236,23 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
subFile + ".csv";
#else
std::string("c:\\Intel\\") + subFile + ".csv";
---- IGC/common/igc_regkeys.hpp.orig 2019-11-27 01:05:20 UTC
+--- IGC/common/igc_regkeys.hpp.orig 2021-07-18 10:00:28 UTC
+++ IGC/common/igc_regkeys.hpp
-@@ -39,7 +39,7 @@ typedef char debugString[256];
+@@ -22,7 +22,7 @@ typedef char debugString[256];
#define IGC_DEBUG_VARIABLES
#endif
--#if defined( __linux__ )
-+#if !defined( __APPLE__ ) && !defined( _WIN32 )
+-#if defined(__linux__)
++#if !defined(__APPLE__) && !defined(_WIN32)
#define IGC_DEBUG_VARIABLES
#endif
-@@ -67,7 +67,7 @@ struct SRegKeyVariableMetaData
+@@ -52,7 +52,7 @@ struct SRegKeyVariableMetaData
}
};
--#if defined ( __linux__ ) && !defined( _DEBUG ) && !defined( _INTERNAL )
-+#if !defined ( _WIN32 ) && !defined( _DEBUG ) && !defined( _INTERNAL )
+-#if defined (__linux__) && !defined(_DEBUG) && !defined(_INTERNAL)
++#if !defined(_WIN32) && !defined(_DEBUG) && !defined(_INTERNAL)
#define LINUX_RELEASE_MODE
#endif
diff --git a/devel/intel-graphics-compiler/pkg-plist b/devel/intel-graphics-compiler/pkg-plist
index 7f2a6935c234..968e8aebed31 100644
--- a/devel/intel-graphics-compiler/pkg-plist
+++ b/devel/intel-graphics-compiler/pkg-plist
@@ -47,6 +47,7 @@ include/igc/cif/cif/os/lin/lin_library_handle.h
include/igc/cif/cif/os/win/win_library_handle.cpp
include/igc/cif/cif/os/win/win_library_handle.h
include/igc/cif/readme.txt
+include/igc/common/StateSaveAreaHeader.h
include/igc/igc.opencl.h
include/igc/ocl_igc_interface/code_type.h
include/igc/ocl_igc_interface/fcl_ocl_device_ctx.h