aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2024-07-01 10:05:19 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2024-07-01 10:05:19 +0000
commita1490b259251fe09f42ec55658a0f2c5d89a2479 (patch)
tree8b8144b84136b1196b959025fd75e192577bd6b8
parent859673fe19d4c6f3152045dc7a1509294f35bf7d (diff)
downloadports-a1490b259251fe09f42ec55658a0f2c5d89a2479.tar.gz
ports-a1490b259251fe09f42ec55658a0f2c5d89a2479.zip
emulators/wine-devel: Sync files/wine.sh with emulators/wine
This forward ports the following two commits from emulators/wine as far as files/wine.sh goes: commit ef11261971a87d2b75b352ab479b651d2f2b0b50 Author: Gerald Pfeifer <gerald@FreeBSD.org> Date: Wed Jan 31 12:27:21 2024 +0000 emulators/wine: Simplify the logic in wine.sh and commit 0f2052c3784e3b8d5aed85aab22b8a49613ee85c Author: Alexander Vereeken <Alexander88207@protonmail.com> Date: Sun Dec 17 22:58:41 2023 +0000 emulators/wine: Unbreak WoW64 This is an excerpt of 1f07ec6014 by Alex S <iwtcex@gmail.com> for emulators/wine-proton. PR: 275677, 279927 Reported by: scf
-rw-r--r--emulators/wine-devel/Makefile1
-rw-r--r--emulators/wine-devel/files/wine.sh9
2 files changed, 7 insertions, 3 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index a91c963d466d..1a9a09b5679b 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wine
DISTVERSION= 9.11
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= https://dl.winehq.org/wine/source/9.x/
diff --git a/emulators/wine-devel/files/wine.sh b/emulators/wine-devel/files/wine.sh
index 96a350fce615..ebd89e55ebdc 100644
--- a/emulators/wine-devel/files/wine.sh
+++ b/emulators/wine-devel/files/wine.sh
@@ -2,9 +2,12 @@
TARGET="$(realpath "$0")"
-if [ -z "$WINESERVER" ] && [ -f "${TARGET}server32" ]
-then
- export WINESERVER="${TARGET}server32"
+if [ -z "$WINESERVER" ]; then
+ if [ -f "${TARGET%/*}/wineserver32" ]; then
+ export WINESERVER="${TARGET%/*}/wineserver32"
+ elif [ -f "${TARGET%/*}/wineserver" ]; then
+ export WINESERVER="${TARGET%/*}/wineserver"
+ fi
fi
# Workaround for https://bugs.winehq.org/show_bug.cgi?id=50257