aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2023-02-11 02:51:58 +0000
committerMikhail Teterin <mi@FreeBSD.org>2023-02-11 02:51:58 +0000
commita162c35141e13918488b9924b82f5b7cce591260 (patch)
tree21a6aa7efe88f390bbf5c5646ef55c947698081f
parent88dba00f7c652607265825e8e5dae5b60dc07d36 (diff)
downloadports-a162c35141e13918488b9924b82f5b7cce591260.tar.gz
ports-a162c35141e13918488b9924b82f5b7cce591260.zip
www/tclhttpd: deal with the new clang's hatred for K&R
-rw-r--r--www/tclhttpd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index 189e31b1c910..9a0851097447 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= dtplite:devel/tcllib
USE_RC_SUBR= tclhttpd
-USES= tcl:tea
+USES= tcl:tea compiler
.include <bsd.port.pre.mk>
@@ -44,4 +44,8 @@ post-install:
${FILESDIR}/pkgIndex.tcl >> \
${STAGEDIR}${PREFIX}/lib/${PORTNAME}${PORTVERSION}/pkgIndex.tcl
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+CFLAGS+= -std=c90 -Wno-deprecated-non-prototype
+.endif
+
.include <bsd.port.post.mk>