aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-08-16 19:04:27 +0000
committerDan Langille <dvl@FreeBSD.org>2021-08-16 19:04:27 +0000
commita18b67648acfe73e6aeaec95b1d9bab9c8b178fa (patch)
treeefb56532752186f62ce693233f27dbd2e5d41a37
parentee72355b3b461896796688e80d03504691545c55 (diff)
downloadports-a18b67648acfe73e6aeaec95b1d9bab9c8b178fa.tar.gz
ports-a18b67648acfe73e6aeaec95b1d9bab9c8b178fa.zip
net/exabgp4: Update to 4.2.13
Allow Python 3.6+ re: https://github.com/Exa-Networks/exabgp/releases/tag/4.2.13 Approved by: zi (maintainer) via private communication
-rw-r--r--net/exabgp4/Makefile4
-rw-r--r--net/exabgp4/distinfo6
-rw-r--r--net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py11
3 files changed, 5 insertions, 16 deletions
diff --git a/net/exabgp4/Makefile b/net/exabgp4/Makefile
index 5c2ebe92ba80..f7cbe6df635d 100644
--- a/net/exabgp4/Makefile
+++ b/net/exabgp4/Makefile
@@ -1,7 +1,7 @@
# Created by: Ryan Steinmetz <zi@FreeBSD.org>
PORTNAME= exabgp
-PORTVERSION= 4.2.11
+PORTVERSION= 4.2.13
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GH \
@@ -15,7 +15,7 @@ COMMENT= BGP engine and route injector
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENCE.txt
-USES= python:3.6-3.7 shebangfix
+USES= python:3.6+ shebangfix
USE_PYTHON= distutils autoplist
CONFLICTS_INSTALL= exabgp-[0-9]*
diff --git a/net/exabgp4/distinfo b/net/exabgp4/distinfo
index b8883ed98ab7..e716edc2b350 100644
--- a/net/exabgp4/distinfo
+++ b/net/exabgp4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598383902
-SHA256 (Exa-Networks-exabgp-4.2.11_GH0.tar.gz) = 3a291cf4906671b6c929b601ca41340ffb3b4e4ccd50ac41a9cbc32777ee39ca
-SIZE (Exa-Networks-exabgp-4.2.11_GH0.tar.gz) = 2931753
+TIMESTAMP = 1628777729
+SHA256 (Exa-Networks-exabgp-4.2.13_GH0.tar.gz) = 13add263c895fe4459bd4b62b92a1299c7039dcd99d3b074464e3c19029ad5e7
+SIZE (Exa-Networks-exabgp-4.2.13_GH0.tar.gz) = 2932003
diff --git a/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py b/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py
deleted file mode 100644
index 5b28bb91408e..000000000000
--- a/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/exabgp/reactor/network/outgoing.py.orig 2021-06-02 13:31:16 UTC
-+++ lib/exabgp/reactor/network/outgoing.py
-@@ -53,6 +53,8 @@ class Outgoing(Connection):
- connect(self.io, self.peer, self.port, self.afi, self.md5)
- return None
- except NetworkError as exc:
-+ self.io.close()
-+ self.io = None
- return exc
-
- def establish(self):