aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-17 17:58:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-18 00:51:57 +0000
commita1b1b9acaa2bd45afda8d0da4a9ad08e8a483781 (patch)
tree6064778647b56f2fa45a8ff5fe72c3adfdaca1fa
parentdf465b54f4cd6f45eb2225f216bc208780094d71 (diff)
downloadports-a1b1b9acaa2bd45afda8d0da4a9ad08e8a483781.tar.gz
ports-a1b1b9acaa2bd45afda8d0da4a9ad08e8a483781.zip
emulators/yuzu: update to s20210917
Changes: https://github.com/yuzu-emu/yuzu/compare/e4d9814ec...6d7801deb (cherry picked from commit f2297d3e29d1ea3d04bf47ede23ab9fcb5e87b78)
-rw-r--r--emulators/yuzu/Makefile4
-rw-r--r--emulators/yuzu/distinfo6
-rw-r--r--emulators/yuzu/files/patch-sdl229
3 files changed, 25 insertions, 14 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 1549a6c3af54..577c897d4f8a 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yuzu
-PORTVERSION= s20210915
+PORTVERSION= s20210917
PORTREVISION?= 0
CATEGORIES= emulators
@@ -34,7 +34,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
USE_GITHUB= yes
GH_ACCOUNT= yuzu-emu
-GH_TAGNAME= e4d9814ec
+GH_TAGNAME= 6d7801deb
GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-115-g8c88150ca:mbedtls/externals/mbedtls \
KhronosGroup:SPIRV-Headers:1.5.4.raytracing.fixed-32-ga3fdfe8:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
KhronosGroup:Vulkan-Headers:v1.2.180:Vulkan_Headers/externals/Vulkan-Headers \
diff --git a/emulators/yuzu/distinfo b/emulators/yuzu/distinfo
index 3f2e7a00658c..30c686274ae6 100644
--- a/emulators/yuzu/distinfo
+++ b/emulators/yuzu/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1631749448
-SHA256 (yuzu-emu-yuzu-s20210915-e4d9814ec_GH0.tar.gz) = bf5220d954d1ab44f683247dc6d29d8502377af3eda441761fa61eb4632c425a
-SIZE (yuzu-emu-yuzu-s20210915-e4d9814ec_GH0.tar.gz) = 3971812
+TIMESTAMP = 1631924751
+SHA256 (yuzu-emu-yuzu-s20210917-6d7801deb_GH0.tar.gz) = 648101745d291db51dcc460f9a58247963909893ed7d0192ca8f4fe3a4392b60
+SIZE (yuzu-emu-yuzu-s20210917-6d7801deb_GH0.tar.gz) = 3972453
SHA256 (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 8cd6d075b4da0ad5fb995eb37390e2e6088be8d41ab1cdfc7e7e4256bd991450
SIZE (yuzu-emu-mbedtls-v2.16.9-115-g8c88150ca_GH0.tar.gz) = 2679189
SHA256 (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-32-ga3fdfe8_GH0.tar.gz) = bd629d6296dd374eb2aeff923c75895ba0f3ce6448dad89763930e65b954e0cb
diff --git a/emulators/yuzu/files/patch-sdl2 b/emulators/yuzu/files/patch-sdl2
index a96a8f81de69..37341e782041 100644
--- a/emulators/yuzu/files/patch-sdl2
+++ b/emulators/yuzu/files/patch-sdl2
@@ -19,7 +19,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
# Some installations don't set SDL2_LIBRARIES
if("${SDL2_LIBRARIES}" STREQUAL "")
---- src/input_common/sdl/sdl_impl.cpp.orig 2021-08-14 09:28:59 UTC
+--- src/input_common/sdl/sdl_impl.cpp.orig 2021-09-18 00:25:51 UTC
+++ src/input_common/sdl/sdl_impl.cpp
@@ -64,6 +64,7 @@ class SDLJoystick { (public)
}
@@ -68,13 +68,15 @@ CMake Error at CMakeLists.txt:397 (find_package):
case SDL_JOYDEVICEREMOVED:
LOG_DEBUG(Input, "Controller removed with Instance_ID {}", event.jdevice.which);
CloseJoystick(SDL_JoystickFromInstanceID(event.jdevice.which));
-@@ -890,11 +896,15 @@ SDLState::SDLState() {
+@@ -890,20 +896,26 @@ SDLState::SDLState() {
RegisterFactory<MotionDevice>("sdl", motion_factory);
- // Disable raw input. When enabled this setting causes SDL to die when a web applet opens
+ if (!Settings::values.enable_raw_input) {
+#if SDL_VERSION_ATLEAST(2,0,14)
- SDL_SetHint(SDL_HINT_JOYSTICK_RAWINPUT, "0");
+ // Disable raw input. When enabled this setting causes SDL to die when a web applet opens
+ SDL_SetHint(SDL_HINT_JOYSTICK_RAWINPUT, "0");
+#endif
+ }
// Enable HIDAPI rumble. This prevents SDL from disabling motion on PS4 and PS5 controllers
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS4_RUMBLE, "1");
@@ -82,9 +84,18 @@ CMake Error at CMakeLists.txt:397 (find_package):
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS5_RUMBLE, "1");
+#endif
++#if SDL_VERSION_ATLEAST(2,0,16)
// Tell SDL2 to use the hidapi driver. This will allow joycons to be detected as a
// GameController and not a generic one
-@@ -1108,6 +1118,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
+ SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_JOY_CONS, "1");
+
+ // Turn off Pro controller home led
+ SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_SWITCH_HOME_LED, "0");
++#endif
+
+ // If the frontend is going to manage the event loop, then we don't start one here
+ start_thread = SDL_WasInit(SDL_INIT_JOYSTICK) == 0;
+@@ -1110,6 +1122,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
}
break;
}
@@ -92,7 +103,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
case SDL_CONTROLLERSENSORUPDATE: {
bool is_motion_shaking = false;
constexpr float gyro_threshold = 5.0f;
-@@ -1137,6 +1148,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
+@@ -1139,6 +1152,7 @@ Common::ParamPackage SDLEventToMotionParamPackage(SDLS
}
break;
}
@@ -100,7 +111,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
}
return {};
}
-@@ -1242,6 +1254,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
+@@ -1244,6 +1258,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
auto sl_button = SDL_CONTROLLER_BUTTON_LEFTSHOULDER;
auto sr_button = SDL_CONTROLLER_BUTTON_RIGHTSHOULDER;
@@ -108,7 +119,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
if (joystick->IsJoyconLeft()) {
sl_button = SDL_CONTROLLER_BUTTON_PADDLE2;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE4;
-@@ -1250,6 +1263,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
+@@ -1252,6 +1267,7 @@ ButtonBindings SDLState::GetNintendoButtonBinding(
sl_button = SDL_CONTROLLER_BUTTON_PADDLE3;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE1;
}
@@ -116,7 +127,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
return {
std::pair{Settings::NativeButton::A, SDL_CONTROLLER_BUTTON_A},
-@@ -1550,7 +1564,9 @@ class SDLMotionPoller final : public SDLPoller { (publ
+@@ -1552,7 +1568,9 @@ class SDLMotionPoller final : public SDLPoller { (publ
[[fallthrough]];
case SDL_JOYBUTTONUP:
case SDL_JOYHATMOTION: